Bug 197590 - Incorrect hint for private enum classes
Incorrect hint for private enum classes
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
7.0
PC Windows XP
: P3 (vote)
: 7.0.1
Assigned To: Jan Lahoda
issues@editor
70patch1-verified
:
: 197933 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-09 13:08 UTC by choces
Modified: 2011-05-20 08:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description choces 2011-04-09 13:08:48 UTC
For all enum class declaration, like the following one:

public class Test {

    private enum EnumTest {

        test1, test2;
    }
}

Hints show up insisting the enum class is public, so suggesting to move it to outer.
Comment 1 Quality Engineering 2011-04-12 08:41:19 UTC
Integrated into 'main-golden', will be available in build *201104120401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/864bb7f9e570
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #197590: Tree.Kind.CLASS=>Tree.Kind.ANNOTATION_TYPE,CLASS,ENUM,INTERFACE.
Comment 2 Jan Lahoda 2011-04-12 14:46:58 UTC
Fixed by the above changeset.
Comment 3 Jan Lahoda 2011-04-21 07:53:16 UTC
*** Bug 197933 has been marked as a duplicate of this bug. ***
Comment 4 Jaromir Uhrik 2011-05-16 20:05:15 UTC
Verified in the following trunk build:
Product Version: NetBeans IDE Dev (Build 201105160400)
Java: 1.6.0_25; Java HotSpot(TM) Client VM 20.0-b11
System: Windows 7 version 6.1 running on x86; Cp1250; cs_CZ (nb)
Comment 5 Jan Lahoda 2011-05-17 12:12:06 UTC
Applied to release70_fixes:
http://hg.netbeans.org/releases/rev/bf4de5da44fa
Spec. versions and long descriptions updated:
http://hg.netbeans.org/releases/rev/ab821ef74098
Comment 6 Jaromir Uhrik 2011-05-20 08:03:19 UTC
Verified in the following build + patch1:
Product Version: NetBeans IDE 7.0 (Build 201104080000)
Java: 1.6.0_25; Java HotSpot(TM) Client VM 20.0-b11
System: Windows 7 version 6.1 running on x86; Cp1250; cs_CZ (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo