Bug 197579 - SVN "merge" dialog is misleading
SVN "merge" dialog is misleading
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.0.1
PC Mac OS X
: P2 (vote)
: 7.1
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 17:34 UTC by athompson
Modified: 2011-08-21 08:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
merge dialog (77.89 KB, image/png)
2011-04-08 17:34 UTC, athompson
Details
search revisions dialog (46.62 KB, image/png)
2011-04-08 17:35 UTC, athompson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description athompson 2011-04-08 17:34:49 UTC
Created attachment 107617 [details]
merge dialog

1. right-click on a SVN-controlled folder and select "Subversion>Merge Changes..."
2! in the "Merge From" dropdown, select "One Repository Folder" (second option)

This is where the dialog gets misleading.  Any change from the revision number you put in the "Starting Revision" field is NOT considered for the merge.  For exmample, if you enter revision 6646, the changes that occur in revision 6646 aren't included.  Only changes from 6647 and beyond are.

One can argue that that's how SVN works under the hood (with "diff"), but people who aren't experts at subversion won't know that.  Things get even more misleading if you use the Search Revisions  dialog to select the revision.  In this dialog, you're actually highlighting a specific revision (identified by it's revision comment), which very strongly implies that revision will be included in the merge.

Additionally, the common use-case where you are just merging a single revision is counter-intuitive.  In that case you must subtract one from the revision number and put that in the "start" box, and put the actual revision number in the "end" box.

I'm not sure what the best solution is, but I do know that everyone I've observed gets this wrong the first time (myself included, and I consider myself an SVN expert).

PS - There should also be a way to merge just the changes since the last merge.  SVN has been capable of this for years now and it's immensely useful.
Comment 1 athompson 2011-04-08 17:35:50 UTC
Created attachment 107618 [details]
search revisions dialog
Comment 2 Tomas Stupka 2011-04-11 12:29:14 UTC
actually two issues here:
1.) misleading rev handling in merge
2.) merge tracking - covered by issue #149915

ad 1.) agree, the behavior might be confusing for newcomers, nevertheless it was designed like that to stay conform with how the commandline client works. Whereas we fully agree with your argumentation, we can also imagine other users complaining that the revision start/end semantics are different to what they are used from the cli. 

posible improvements:
- provide a preview (--dry-run)  - see #73089
- better visualization what revisions will be merged (similar to how the merge paths are already shown)


this isn't the first report of this kind so raising priority - see also #124312 (won't set us duplicate to #73089 for now)

this is WAD -> enhancement
Comment 3 Ondrej Vrabec 2011-08-04 16:29:46 UTC
i suggest adding a checkbox (by default selected) under Started revision field: "Include in merge". If selected than the start revision will be decreased by 1, if deselected the behavior will remain the same as now.
Comment 4 Ondrej Vrabec 2011-08-05 07:39:15 UTC
fix: http://hg.netbeans.org/core-main/rev/eacd9cbd07bb
Comment 5 Quality Engineering 2011-08-06 14:00:38 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/eacd9cbd07bb
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #197579 - SVN "merge" dialog is misleading
Comment 6 athompson 2011-08-17 17:38:14 UTC
Works ok.  I would suggest moving the checkbox to the same line as the starting revision and change the wording to "Include this revision in merge" to make what it does more clear.
Comment 7 Ondrej Vrabec 2011-08-18 07:29:18 UTC
fix: http://hg.netbeans.org/core-main/rev/abdf74ba5240
Comment 8 Quality Engineering 2011-08-19 14:41:58 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/abdf74ba5240
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #197579 - SVN "merge" dialog is misleading
changing the wording of a checkbox
Comment 9 athompson 2011-08-21 08:41:17 UTC
yup


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo