Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 197574 - RFE: Unneeded code detection.
RFE: Unneeded code detection.
Status: RESOLVED DUPLICATE of bug 181458
Product: java
Classification: Unclassified
Component: Refactoring
6.x
PC Linux
: P3 with 4 votes (vote)
: TBD
Assigned To: Jan Becicka
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 13:51 UTC by pekarna
Modified: 2016-03-25 13:37 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pekarna 2011-04-08 13:51:47 UTC
Would be great if NetBeans had a plugin like this:
http://www.ucdetector.org/

In short, it analyzes clusters of types and their relations, and suggests what is probably not needed - because the cluster is e.g. not used anywhere, or only used in tests, etc. It also gives advices on what method is public but is only used inside a class, etc.

There are some discussions on this:
* http://stackoverflow.com/questions/3519711/something-like-unnecessary-code-detector-for-netbeans
* http://forums.netbeans.org/topic9556.html
Comment 1 bmaras 2013-07-11 15:23:55 UTC
Isn't it a duplicate of https://netbeans.org/bugzilla/show_bug.cgi?id=181458 ?
Comment 2 markiewb 2016-03-25 13:37:59 UTC
duplicate of https://netbeans.org/bugzilla/show_bug.cgi?id=181458 ?

*** This bug has been marked as a duplicate of bug 181458 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo