Bug 197562 - MacOSX: Can't finish debugger if new invalid watch is added (invalid in current context)
MacOSX: Can't finish debugger if new invalid watch is added (invalid in curre...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
7.0
PC Mac OS X
: P2 (vote)
: 7.0.1
Assigned To: Egor Ushakov
issues@cnd
:
: 197991 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 11:09 UTC by soldatov
Modified: 2011-06-03 10:50 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-04-08 11:09:44 UTC
Scenario:
- Create InputOutput project
- Push Step into
- Add 'i' new watch
- Push Finish button
==> debugger hangs on "24-gdb-exit" command in Debugger Console

Workaround: restart IDE only
Comment 1 Leonid Lenyashin 2011-04-13 15:15:38 UTC
Any evaluation?
Comment 2 Alexander Pepin 2011-04-13 15:27:27 UTC
In 6.9.1 we also had problems with watches on Mac due to gdb 6.3.5 ant this problem appeared after fixing some of "watches" issues. I believe we should try to fix it in the patch.
Comment 3 stiffuser 2011-04-15 19:24:37 UTC
I'm experiencing the same issue. Every time a watch is deemed invalid, debugging stops to work and the IDE has to be restarted.
Comment 4 Alexander Pepin 2011-04-25 08:52:08 UTC
*** Bug 197991 has been marked as a duplicate of this bug. ***
Comment 5 Egor Ushakov 2011-05-23 16:40:41 UTC
it is a bug of gdb on MacOSX, steps to reproduce:
>gdb --interpreter=mi ./quote_4
>b main
>r
>-var-create - @ xxx
>-var-show-attributes "var1"
Bus error
and gdb silently crashes after that

I will add a special check for that on macosx
Comment 6 Egor Ushakov 2011-05-26 15:20:33 UTC
fixed in:
http://hg.netbeans.org/releases/rev/4002f7e16ffe
Comment 7 Quality Engineering 2011-05-27 11:56:56 UTC
Integrated into 'main-golden', will be available in build *201105270401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/16e9a7fe7b72
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #197562 (MacOSX: Can't finish debugger if new invalid watch is added (invalid in current context))
(transplanted from 4002f7e16ffe3e44d6f7629027caccb80b73eddf)
Comment 8 soldatov 2011-06-03 10:50:00 UTC
verified
NetBeans IDE 7.0.1 Dev (Build 201106030000)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo