Bug 197546 - IDE gets stuck on "Find Usages" on non-classpath Maven project dependency
IDE gets stuck on "Find Usages" on non-classpath Maven project dependency
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
PC Linux
: P3 (vote)
: 7.1
Assigned To: Jesse Glick
issues@projects
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-07 17:15 UTC by pekarna
Modified: 2011-08-11 21:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
UI blocked while repos are reindexed (23.18 KB, text/plain)
2011-04-11 15:21 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pekarna 2011-04-07 17:15:58 UTC
STR:

1) Have a project with a dependency of <type>pom</type>.
   (NetBeans shows this with an "a" icon.)
2) In Projects view, right-click on this dependency, choose Find Usages.
3) IDE gets stuck.

Can be reproduced with commit
  [tomcat 6bfebd8] Fixing JMX.
of 
  git@github.com:OndraZizka/arquillian.git

By loading whole root project and loading dependencies of the module Containers > Tomcat Remote.
Comment 1 pekarna 2011-04-07 17:17:28 UTC
NetBeans IDE Build 201102280001
Comment 2 pekarna 2011-04-07 17:28:22 UTC
It seems that NetBeans is actualy doing something in the background, because after doing this, there's some network and disk i/o activity, shifting in rounds - some downloading, then disk write, and then again.

Also, to get to the "a" dependency, one need to first double-click the node labelled "There's 1 non-classpath dependency." So STR should go like:

1) Have a project with a dependency of <type>pom</type>.
2) In Projects view, double-click the node labelled "There's 1 non-classpath dependency." New dependency appears, having an "a" icon.
3) Right-click on this "a" dependency, choose Find Usages.
4) IDE gets stuck, with shifting network download and disk write activity.
Comment 3 Marian Mirilovic 2011-04-08 11:51:14 UTC
could you please generate thread-dump at time of stuck http://wiki.netbeans.org/GenerateThreadDump, attach it here and reopen ? Thanks in advance.
Comment 4 Jesse Glick 2011-04-11 15:20:18 UTC
Steps to reproduce suffice.
Comment 5 Jesse Glick 2011-04-11 15:21:33 UTC
Created attachment 107641 [details]
UI blocked while repos are reindexed
Comment 6 Jesse Glick 2011-08-10 21:15:25 UTC
core-main #ae51b1fe5e00
Comment 7 Jesse Glick 2011-08-10 21:30:40 UTC
Fix was simply to skip unindexed repos. Alternative would be to search all repos but show a progress handle while doing so. I do not have a strong feeling about which is preferable; this was certainly simpler.
Comment 8 Quality Engineering 2011-08-11 21:01:06 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/ae51b1fe5e00
User: Jesse Glick <jglick@netbeans.org>
Log: #197546: IDE gets stuck on "Find Usages" on non-classpath Maven project dependency


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo