Bug 197525 - IDE lockup during "opening projects"
IDE lockup during "opening projects"
Status: RESOLVED DUPLICATE of bug 197510
Product: projects
Classification: Unclassified
Component: Maven
7.0.1
PC Linux
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-07 09:43 UTC by kawazu428
Modified: 2011-04-07 14:04 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (29.31 KB, text/plain)
2011-04-07 09:44 UTC, kawazu428
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kawazu428 2011-04-07 09:43:51 UTC
Using build 201104030400 and a small set of projects (11 maven2 web artifacts, Java EE 6, including JPA, JAX-RS and some JavaScript stuff, SVN managed), as of today the IDE doesn't start up anymore. Tried this three times now, things reproducibly lock up at 9% during "opening projects". By then the UI becomes completely unresponsive, no UI interactions are possible anymore. Thread dump attached.
Comment 1 kawazu428 2011-04-07 09:44:19 UTC
Created attachment 107582 [details]
thread dump
Comment 2 Marian Mirilovic 2011-04-07 12:09:04 UTC
dup of issue 197510 ?
Comment 3 Jesse Glick 2011-04-07 14:04:10 UTC
Similar to bug #197510, but a little different; here EndorsedClassPathImpl.getResources asked for indexed repos but seems to have gotten one which had an out-of-date index that needed to be refreshed.

*** This bug has been marked as a duplicate of bug 197510 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo