Bug 197515 - java.io.FileNotFoundException: C:\Users\Abdi\.netbeans\7.0beta2\var\cache\index\s68\java\14\refs\_c0.prx (The system cannot find the file specified)
java.io.FileNotFoundException: C:\Users\Abdi\.netbeans\7.0beta2\var\cache\ind...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
7.0
All All
: P2 with 1 vote (vote)
: 7.1
Assigned To: Tomas Zezula
issues@editor
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-06 21:30 UTC by Abdis
Modified: 2011-12-01 12:10 UTC (History)
17 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.12 KB, text/plain)
2011-04-06 21:30 UTC, Abdis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Abdis 2011-04-06 21:30:18 UTC
Build: NetBeans IDE 7.0 Beta 2 (Build 201102140001)
VM: Java HotSpot(TM) Client VM, 16.0-b03, Java(TM) SE Runtime Environment, 1.7.0-ea-b59
OS: Windows 7

User Comments:
GUEST: Just was starting up NB.  3 projects were already loaded.  Loaded 3 more.  The error came up during completion of the load.  I see no ill effects on the projects however.

Abdis: Sent to U




Stacktrace: 
java.io.FileNotFoundException: C:\Users\Abdi\.netbeans\7.0beta2\var\cache\index\s68\java\14\refs\_c0.prx (The system cannot find the file specified)
   at java.io.RandomAccessFile.open(RandomAccessFile.java:0)
   at java.io.RandomAccessFile.<init>(RandomAccessFile.java:233)
   at org.apache.lucene.store.SimpleFSDirectory$SimpleFSIndexInput$Descriptor.<init>(SimpleFSDirectory.java:76)
   at org.apache.lucene.store.SimpleFSDirectory$SimpleFSIndexInput.<init>(SimpleFSDirectory.java:97)
   at org.apache.lucene.store.SimpleFSDirectory.openInput(SimpleFSDirectory.java:63)
   at org.apache.lucene.index.SegmentReader$CoreReaders.<init>(SegmentReader.java:136)
Comment 1 Abdis 2011-04-06 21:30:21 UTC
Created attachment 107568 [details]
stacktrace
Comment 2 Marian Mirilovic 2011-09-20 10:10:32 UTC
104 reports .. at least P2
Comment 3 Tomas Zezula 2011-10-17 09:17:37 UTC
Seems as a Lucene issue as the index is locked during merge.
Without debugStream hard to say what has happened, the generation file contains reference to non existent data file.
We should try to update the Lucene to 3.4.0.
Comment 4 Tomas Zezula 2011-11-28 17:56:26 UTC
Caused by the update to the Lucene 3.0.3
The problem happens only on Windows.
Comment 5 Tomas Zezula 2011-11-28 18:03:56 UTC
The update to Lucene 3.3.x may solve problem.
Comment 6 Tomas Zezula 2011-11-29 14:33:21 UTC
I am not able to reproduce it even on Windows.
The problem may be in change optimize behavior, changing to behave as in 2.9.x.
Fixed jet-main 56490c970a32
Comment 7 Tomas Zezula 2011-11-29 15:14:07 UTC
Originally I've thought that it's caused by delayed IO on NTFS (the problem happens only on Windows).
But it seems not to be true, the file is missing for long time (found from other log).
Second try was broken index (the file is missing in the start of the IDE) but in this case the exception will have different stack trace and will be cached and IDE recovers from it.
The real reason of the exception is unknown for now. The fix just tries to change the Lucene merge behavior as it was in previous version.
Comment 8 Tomas Zezula 2011-11-29 17:35:33 UTC
One more, jet-main 38001c4025a6
Comment 10 Quality Engineering 2011-11-30 07:12:34 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/05b79fed0b80
User: Tomas Zezula <tzezula@netbeans.org>
Log: #197515:java.io.FileNotFoundException: C:\Users\Abdi\.netbeans\7.0beta2\var\cache\index\s68\java\14\refs\_c0.prx (The system cannot find the file specified)
Comment 11 Quality Engineering 2011-12-01 12:10:36 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/56490c970a32
User: Tomas Zezula <tzezula@netbeans.org>
Log: #197515:java.io.FileNotFoundException: C:\Users\Abdi\.netbeans\7.0beta2\var\cache\index\s68\java\14\refs\_c0.prx (The system cannot find the file specified)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo