Bug 197495 - When adding JSF framework, incorrect library (JSP compilation) is offered
When adding JSF framework, incorrect library (JSP compilation) is offered
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
7.0
PC All
: P1 (vote)
: 7.0
Assigned To: Martin Fousek
issues@javaee
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-06 13:48 UTC by Petr Jiricka
Modified: 2011-04-08 08:50 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2011-04-06 13:48:34 UTC
1. Create a web project, GF 3.1 as target server
2. On the Frameworks page, check JSF
3. In the Registered Libraries, "JSP Compilation" is offered, which is incorrect. 

BTW, shouldn't the "Server Library" option be present and pre-selected in this case?

Could this be a regression from fix of bug 192308?
Comment 1 Anton Chechel 2011-04-06 14:09:59 UTC
Yes, I have added registration of jsp-compilation-syscp library in all places where jsp-compilation was already:

http://hg.netbeans.org/web-main/rev/bb8483e9247d
===
     9.1 --- a/web.project/src/org/netbeans/modules/web/project/ui/customizer
/CustomizerLibraries.java
     9.2 +++ b/web.project/src/org/netbeans/modules/web/project/ui/customizer/CustomizerLibraries.java
     9.3 @@ -921,6 +921,7 @@
     9.4          // make jsp compilation libraries sharable if jsp compilation is ticked on
     9.5          if (uiProperties.COMPILE_JSP_MODEL.isSelected()) {
     9.6              libs.add("jsp-compilation"); // NOI18N
     9.7 +            libs.add("jsp-compilation-syscp"); // NOI18N
     9.8              libs.add("jsp-compiler"); // NOI18N
     9.9          }
===
But as you see jsp-compilation and jsp-compiler was there before. so I predict this is correct behavior.

Is it really P1?
Comment 2 Jiri Skrivanek 2011-04-06 15:41:02 UTC
"JSP Compilation" is not offered in build 201103210400, so it really seems to be a regression.
Comment 3 David Konecny 2011-04-06 22:40:10 UTC
I'm going to have a look at it but my guess is that population of available JSF libraries is done based on presence of some specific JSF class. And in issue 192308 we added JSF API to 'JSP compilation' library. Hotfix is to filter 'JSP compilation' from list of suitable JSF libraries.
Comment 4 David Konecny 2011-04-06 23:14:40 UTC
The fix is trivial as there is already a mechanism for filtering out unwanted libraries in place. I just added the name of additional library to exclude. See 25fe1a2389b8 in web-main which I just pushed.
Comment 5 Martin Fousek 2011-04-07 04:51:08 UTC
Reviewed, verified - simply, totally safe fix.
Comment 6 Marian Mirilovic 2011-04-07 05:50:14 UTC
(In reply to comment #5)
> Reviewed, verified - simply, totally safe fix.

Ok, please integrate into release70 ASAP. Thanks in advance.
Comment 7 Martin Fousek 2011-04-07 06:02:48 UTC
Integrated into release70 by http://hg.netbeans.org/releases/rev/04aa9273784e.
Comment 8 David Konecny 2011-04-07 09:26:07 UTC
(In reply to comment #7)
> Integrated into release70 by http://hg.netbeans.org/releases/rev/04aa9273784e.

Thanks.
Comment 9 Jiri Skrivanek 2011-04-07 14:10:00 UTC
Verified in NetBeans IDE 7.0 RC2 (Build 201104070802).
Comment 10 Quality Engineering 2011-04-08 08:50:13 UTC
Integrated into 'main-golden', will be available in build *201104080400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/25fe1a2389b8
User: David Konecny <dkonecny@netbeans.org>
Log: #197495 - When adding JSF framework, incorrect library (JSP compilation) is offered


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo