Bug 197493 - MacOSX and Windows: Step Into works as Continue
MacOSX and Windows: Step Into works as Continue
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
7.0
PC Mac OS X
: P3 (vote)
: 7.0.1
Assigned To: Egor Ushakov
issues@cnd
fix-in-nb701
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-06 13:32 UTC by soldatov
Modified: 2011-06-22 14:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
gdb log (8.30 KB, text/plain)
2011-04-06 13:32 UTC, soldatov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-04-06 13:32:36 UTC
Created attachment 107553 [details]
gdb log

Scenario:
- Create Argument project
- Set 2 line breakpoints at 39th and 44th lines
- Push Debug Main Project button
==> debugger stopped at 39th line
- Press F8
==> debugger stopped at 44th line
Comment 1 soldatov 2011-05-03 10:20:54 UTC
I see this problem on Windows XP also (MinGW, gdb 6.8).

Windows XP specific scenario:
- Create Argument project
- Set line breakpoint at 35th line
- Set line breakpoint at 44th line
- Push Debug Main Project button
==> debugger stopped at 35th line
- Press F8
==> debugger stopped at 44th line
Comment 2 soldatov 2011-05-16 09:01:45 UTC
*** Bug 198612 has been marked as a duplicate of this bug. ***
Comment 3 maimuta 2011-05-26 11:48:07 UTC
I and a colleague have also experienced this issue.  We are both running CentOS 5.6 64-bit with NetBeans 7.0, Java 1.6.0_25 64-bit, and gdb 7.0.1-32.el5_6.2 in a VirtualBox VM running on a Windows 7 host.

The debugger always hits breakpoints.  The first time an attempt is made to step (into, over, or out) or to run-to-cursor it acts as if continue was selected.  If another breakpoint is reached after this, stepping and running-to-cursor works as expected.  It does not work, however, until after the first attempt to step or run-to-cursor, no matter how many breakpoints were hit before that.
Comment 4 Egor Ushakov 2011-05-31 10:15:15 UTC
fixed in:
http://hg.netbeans.org/releases/rev/17251aa704cd
Comment 5 Egor Ushakov 2011-05-31 12:46:45 UTC
now it always stops in main
Comment 6 Egor Ushakov 2011-05-31 12:47:44 UTC
original issue appeared because breakpoint on line 39 is actually the same breakpoint as debugger internal breakpoint in main.
Comment 7 Egor Ushakov 2011-05-31 13:22:53 UTC
fixed in:
http://hg.netbeans.org/releases/rev/05fc326fd8e6
Comment 8 Quality Engineering 2011-06-01 13:32:56 UTC
Integrated into 'main-golden', will be available in build *201106010401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ffbe840fc8e8
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #197493 (MacOSX and Windows: Step Into works as Continue)
(transplanted from 17251aa704cd942c35186344a4d147c5a8955e8d)
Comment 9 soldatov 2011-06-03 10:45:20 UTC
verified
NetBeans IDE 7.0.1 Dev (Build 201106030000)
Comment 10 Quality Engineering 2011-06-22 14:04:52 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/cf76a84a855d
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed broken merge for #197493 (MacOSX and Windows: Step Into works as Continue)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo