Bug 197370 - Characters are not painted when using right to left script
Characters are not painted when using right to left script
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.0
All Windows 7 x64
: P1 (vote)
: 7.0
Assigned To: Miloslav Metelka
issues@editor
: 70_HR_FIX, I18N, REGRESSION
: 197379 197438 197576 197631 197803 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-03 22:00 UTC by RandallFlagg
Modified: 2011-05-03 21:22 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RandallFlagg 2011-04-03 22:00:07 UTC
Product Version = NetBeans IDE 7.0 Beta 2 (Build 201102140001)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.6.0_24
Runtime = Java HotSpot(TM) 64-Bit Server VM 19.1-b02


Some of my code isn't showing.

I edited this out side the IDE.
When I came to the IDE it showed me part of the code.

The code was:
<h1>מפת אתר: הזמנט</h1>

I added outside(because for somereason I can't see hebrew even though I chose an unicode font) code so it will look like this:
<header><h1>מפת אתר: הזמנט</h1></header>

And this is what I am seeing in netbeans:
<header><h1></header>
Comment 1 Marian Mirilovic 2011-04-04 07:03:12 UTC
Editor guys/Marek please evaluate ASAP. I tested it on NB RC2 with JDK6u24x64 (Ubuntu10.10x64) and I haven't been able to reproduce.
Comment 2 Miloslav Metelka 2011-04-04 08:18:52 UTC
RandallFlagg: could you please attach your messages.log? Thanks.
Comment 3 Miloslav Metelka 2011-04-04 21:24:59 UTC
I was able to reproduce and I'm working on a fix.
Comment 4 Miloslav Metelka 2011-04-04 21:25:21 UTC
*** Bug 197379 has been marked as a duplicate of this bug. ***
Comment 5 David Strupl 2011-04-05 16:19:37 UTC
*** Bug 197438 has been marked as a duplicate of this bug. ***
Comment 6 Miloslav Metelka 2011-04-05 21:33:40 UTC
I need few more hours to finish the fix. In addition I need to modify PargraphView to not create visual gaps for its children in case there's a RTL text on the line.
I'll finish the fix during tomorrow.
Comment 7 Miloslav Metelka 2011-04-06 22:21:12 UTC
http://hg.netbeans.org/jet-main/rev/2b5f0719dc44
Comment 8 Miloslav Metelka 2011-04-06 22:25:14 UTC
Integrated into release70:
2b5f0719dc44 transplanted to 72eb34c1dc17
Comment 9 Miloslav Metelka 2011-04-07 08:44:56 UTC
Additional fix:
http://hg.netbeans.org/jet-main/rev/7851669f136b
Comment 10 Miloslav Metelka 2011-04-07 08:52:05 UTC
Integrated into release70:
7851669f136b transplanted to 6758885300c3
Comment 11 Vladimir Riha 2011-04-07 13:38:28 UTC
verified
Comment 12 Quality Engineering 2011-04-08 08:51:23 UTC
Integrated into 'main-golden', will be available in build *201104080400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2b5f0719dc44
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #197370 - Characters are not painted when using right to left script.
Comment 13 Miloslav Metelka 2011-04-12 07:43:44 UTC
*** Bug 197631 has been marked as a duplicate of this bug. ***
Comment 14 Miloslav Metelka 2011-04-18 08:19:18 UTC
*** Bug 197803 has been marked as a duplicate of this bug. ***
Comment 15 Miloslav Metelka 2011-05-03 21:22:16 UTC
*** Bug 197576 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo