Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 197267 - PHP code completion is slow
PHP code completion is slow
Status: RESOLVED DUPLICATE of bug 193040
Product: php
Classification: Unclassified
Component: Editor
7.0
PC All
: P2 (vote)
: TBD
Assigned To: Petr Pisl
issues@php
: PERFORMANCE
Depends on:
Blocks: 179727
  Show dependency treegraph
 
Reported: 2011-03-31 08:21 UTC by Dusan Balek
Modified: 2011-03-31 09:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dusan Balek 2011-03-31 08:21:35 UTC
See NPS snapshot in Exception Reporter
Comment 1 Petr Pisl 2011-03-31 09:23:29 UTC
Snapshot from report 461128: During cc the reindexing is started. 
Snapshot from report 461175: CC spen time in index for finding new constructors
Snapshot from report 461178: the same as previous one
Snapshot from report 500376: all the time is spend in apple.awt.CGraphicsEnvironment.getDefaultScreenDevice() -> something wrong with the graphics?

So the second and the third snapshot should show for something wrong in find constructors.
Comment 2 Petr Pisl 2011-03-31 09:51:55 UTC
The two snapshot that shows slow cc for constructors are from builds from November 2010. I have fixed the issue in December as issue #193040. Marking as duplicate of this issue.

*** This bug has been marked as a duplicate of bug 193040 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo