Bug 197223 - Can't use full remote project created with NB6.9.1
Can't use full remote project created with NB6.9.1
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0
PC All
: P1 (vote)
: 7.0
Assigned To: Vladimir Kvashin
issues@cnd
FULL_REMOTE
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 09:48 UTC by soldatov
Modified: 2011-04-05 13:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (16.68 KB, image/png)
2011-03-30 09:50 UTC, soldatov
Details
remote project before import (50.00 KB, application/x-tar)
2011-03-30 09:54 UTC, soldatov
Details
remote project after import (50.00 KB, application/x-tar)
2011-03-30 09:54 UTC, soldatov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-03-30 09:48:30 UTC
WindowsXP without tools (Cygwin,MSYS,MinGW)

Scenario:
- Create Arguments sample on Solaris remote host
- Launch IDE with fresh user directory
- Push Tools|Options window
- Add remote host
- Push Ok button
- Push File|Import Project|Import Import Project... menu item
- Select Existing Development Host and press Next button
- Select remote project location and press Finish button
- Call Project Properties window
==>
Development Host = [localhost] Windows
Tool Collection = OracleSolarisStudio - not found
Comment 1 soldatov 2011-03-30 09:50:36 UTC
Created attachment 107379 [details]
screenshot
Comment 2 soldatov 2011-03-30 09:54:10 UTC
Created attachment 107380 [details]
remote project before import
Comment 3 soldatov 2011-03-30 09:54:40 UTC
Created attachment 107381 [details]
remote project after import
Comment 4 Alexander Pepin 2011-03-30 16:48:12 UTC
Confirmed.
The workaround is to open the project with NB 7.0 and upgrade the project version.
Comment 5 Vladimir Kvashin 2011-03-30 21:26:12 UTC
I see; project metadata structure differs in previous versions, import was tested on recent metadata only, so it imports old metadata incorrectly. I believe it's easy to fix.
Comment 6 Quality Engineering 2011-04-02 08:49:56 UTC
Integrated into 'main-golden', will be available in build *201104020400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2f3616436329
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #197223 Can't use full remote project created with NB6.9.1
Comment 7 Vladimir Kvashin 2011-04-02 11:25:04 UTC
The previous fix was reverted as it was incorrect.

The issue is now fixed in cnd-main:
http://hg.netbeans.org/cnd-main/rev/373e526bd45f
http://hg.netbeans.org/cnd-main/rev/42f556074587

I believe it deserves 70_HR_FIX_CANDIDATE. Otherwise only projects created with 7.0 can be imported in 7.0, which makes the feature unusable.

Just to make sure we won't forget about that, I'm not closing the issue now.
Comment 8 Quality Engineering 2011-04-03 08:38:00 UTC
Integrated into 'main-golden', will be available in build *201104030400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/373e526bd45f
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: refactoring for fixing #197223 Can't use full remote project created with NB6.9.1
Comment 9 Alexander Pepin 2011-04-04 10:20:50 UTC
The fix is verified in dev build #5082. 
Please continue the showstopper process, review the fix and push it into release70 ASAP.
Comment 10 Vladimir Voskresensky 2011-04-04 14:10:01 UTC
reviewed
Comment 12 Alexander Pepin 2011-04-05 13:38:38 UTC
verified in RC2 build 20110405


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo