Bug 197219 - NPE in DirectoryChooserUI
NPE in DirectoryChooserUI
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Directory Chooser
7.0
PC Linux
: P1 (vote)
: 7.0
Assigned To: Ondrej Vrabec
issues@platform
: 70_HR_FIX, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 08:37 UTC by Ondrej Vrabec
Modified: 2011-03-31 11:49 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Vrabec 2011-03-30 08:37:46 UTC
The fix for bug #196940 introduced a nasty regression, taken from an e-mail by Vladimir:
> Below is exceptions report which can not be converted into IZ.
> We'd like it to be fixed in 7.0 (because it is expected to be platform for Solaris Studio IDE.Next)
> The fix is simple:
> check for null after file.listFiles() and exit if null.
> as seen from exception it is in DirectoryChooserUI.ListFilesWorker (line 1070)
> And occurs in case of read only dir in path.
> In NFS env we have such situation rather often when trying to open project from co-worker /home/user/NetBeansProjects folders or other NFS paths 

Should be fixed in 7.0, Marian, do you agree?
Comment 1 Ondrej Vrabec 2011-03-30 08:57:23 UTC
fix: http://hg.netbeans.org/core-main/rev/41234cdb139c
Comment 2 Antonin Nebuzelsky 2011-03-30 11:38:21 UTC
Adding the keyword to keep track of it.
Comment 3 Ondrej Vrabec 2011-03-30 12:09:37 UTC
To reproduce the problem, just enter /blablabla/ into the filename field
Comment 4 Jiri Rechtacek 2011-03-30 12:42:49 UTC
The patch works for me.
Comment 5 Antonin Nebuzelsky 2011-03-30 14:32:31 UTC
Ondreji, please integrate to release70 today. Thanks.
Comment 6 Jaromir Uhrik 2011-03-30 14:51:44 UTC
Verified in the custom build. Ondro, please, integrate now. Thanks.
Comment 7 Ondrej Vrabec 2011-03-30 14:55:15 UTC
fixed in release70: http://hg.netbeans.org/releases/rev/49a55c18a2ac
Comment 8 Quality Engineering 2011-03-31 08:49:09 UTC
Integrated into 'main-golden', will be available in build *201103310400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/41234cdb139c
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #197219 - NPE in DirectoryChooserUI
Comment 9 Jaromir Uhrik 2011-03-31 11:49:20 UTC
I have verified the fix in the following NB7.0 build:
Product Version: NetBeans IDE 7.0 RC2 (Build 201103310000)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Windows 7 version 6.1 running on x86; Cp1250; cs_CZ (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo