Bug 197166 - serious memory leak in html validator
serious memory leak in html validator
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.0
PC Mac OS X
: P1 (vote)
: 7.0
Assigned To: Marek Fukala
issues@javaee
: 70_HR_FIX, PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-28 21:36 UTC by Marek Fukala
Modified: 2011-03-31 08:27 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2011-03-28 21:36:38 UTC
Extracted from the issue #143453, comment #38:

http://netbeans.org/bugzilla/show_bug.cgi?id=143453#c38

According the last attached memory dump it looks like problem in the HTML
validator, because it eats alsmost 250 MB of ram. The problem can be in
REPORTED_RUNTIME_EXCEPTIONS map, which is static and keeps anonymous inner
classes "marker", but IMHO such anonymous class keeps reference into the
enclosing whole instance of ValidationTransaction. 


Assigning to Marek, it his code.

----------------

Petr's evaluation is correct.

fixed in web-main#c6b1d86726a9

Petre, can you please review the fix? I think it must be integrated into 7.0. 

Thanks
Comment 1 Marek Fukala 2011-03-28 21:39:45 UTC
fixed in trunk
Comment 2 Marian Mirilovic 2011-03-29 00:45:39 UTC
I agree with integration into release70.
Comment 3 Petr Pisl 2011-03-29 09:24:10 UTC
The fix seems to be ok for me.
Comment 4 larsomat 2011-03-30 06:48:09 UTC
Confirmed. 

The Issue I reported here:
http://netbeans.org/bugzilla/show_bug.cgi?id=143453#c32
Is fixed.
Comment 5 Marian Mirilovic 2011-03-30 21:48:49 UTC
I guess this is already fixed in release70, isn't it ?
http://hg.netbeans.org/releases/rev/4afa8dc23890
Comment 6 Marek Fukala 2011-03-31 07:16:23 UTC
Yes, the changes has already been transplanted by ppisl.
Comment 7 Petr Pisl 2011-03-31 08:27:27 UTC
I'm sorry I forgot to make the changes here.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo