Bug 197128 - Duplicate FO after FTP download
Duplicate FO after FTP download
Status: RESOLVED DUPLICATE of bug 195141
Product: php
Classification: Unclassified
Component: FTP Support
7.0
All All
: P3 (vote)
: 7.1
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT
:
: 196808 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-27 17:02 UTC by leth
Modified: 2011-06-28 15:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.34 KB, text/plain)
2011-03-27 17:02 UTC, leth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leth 2011-03-27 17:02:19 UTC
This bug was originally marked as duplicate of bug 190319, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.0 Beta 2 (Build 201102201501)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02-334, Java(TM) SE Runtime Environment, 1.6.0_24-b07-334-10M3326
OS: Mac OS X

User Comments:
leth: I downloaded the following files from my server:

Succeeded:
file      wp-content/plugins/wp-maintenance-mode/languages/wp-maintenance-mode-nl_NL.mo                    
file      wp-content/plugins/wp-maintenance-mode/js/jquery.countdown-ko.js                                 
dir       wp-content/plugins/wp-maintenance-mode/css                                                       
file      wp-content/plugins/wp-maintenance-mode/styles/wartung.swf                                        
file      wp-content/plugins/wp-maintenance-mode/screenshot-3.png                                          
file      wp-content/themes/twentyten/images/headers/path.jpg                                              
file      wp-content/plugins/wp-maintenance-mode/languages/wp-maintenance-mode-be_BY.po                    
file      wp-content/plugins/wp-maintenance-mode/styles/images/es/button.png                               
file      wp-content/plugins/wp-maintenance-mode/styles/images/headline-af-




Stacktrace: 
java.lang.IllegalArgumentException: Duplicate in children list: /Users/tleitner/NetBeansProjects/goodbye-europe.net/wp-content/plugins/wp-maintenance-mode/js/jquery.countdown-fr.js
Children: [MasterFileObject[/Users/tleitner/NetBeansProjects/goodbye-europe.net/wp-content/plugins/wp-maintenance-mode/js/de_DE.datetimepicker.js@563afc0c:79ac3b87,valid=true], MasterFileObject[/Users/tleitner/NetBeansProjects/goodbye-europe.net/wp-content/plugins/wp-maintenance-mode/js/jquery.countdown-ar.js@7d869bc7:745ad2de,valid=true], MasterFileObject[/Users/tleitner/NetBeansProjects/goodbye-europe.net/wp-content/plugins/wp-maintenance-mode/js/jquery.countdown-cs.js@99f0a4b:caafeff,valid=true], MasterFileObject[/Users/tleitner/NetBeansProjects/goodbye-europe.net/wp-content/plugins/wp-maintenance-mode/js/jquery.countdown-da.js@44f09a7c:38b930e4,valid=true], MasterFileObject[/Users/tleitner/NetBeansProjects/goodbye-europe.net/wp-content/plugins/wp-maintenance-mode/js/jquery.countdown-de.js@66e136be:4cd452db,valid=true], MasterFi
   at org.openide.filesystems.Ordering.getOrder(Ordering.java:101)
   at org.openide.filesystems.FileUtil.getOrder(FileUtil.java:2162)
   at org.openide.loaders.FolderList.carefullySort(FolderList.java:644)
   at org.openide.loaders.FolderList.createBoth(FolderList.java:889)
   at org.openide.loaders.FolderList.access$700(FolderList.java:77)
   at org.openide.loaders.FolderList$2.run(FolderList.java:402)
Comment 1 leth 2011-03-27 17:02:25 UTC
Created attachment 107313 [details]
stacktrace
Comment 2 Jaroslav Tulach 2011-05-09 14:48:00 UTC
Did this error happen before rewrite of FTP support to fileobjects or before? If before, keep it in PHP.
Comment 3 Tomas Mysik 2011-06-14 21:51:22 UTC
*** Bug 196808 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Mysik 2011-06-28 15:28:01 UTC
Very likely duplicate of issue #195141. If you still can reproduce this issue with development version of NetBeans [1], please reopen this issue and provide exact steps to reproduce.

Thanks for your cooperation.
[1] http://bits.netbeans.org/download/trunk/nightly/latest/

*** This bug has been marked as a duplicate of bug 195141 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo