Bug 197083 - IllegalStateException: Unfinished non-first replace - error during view replacement: view: DV@6c0f0f14#225:<3775,17506>, WxH:2156.0x3375.0; incomingMod=true; lengthyAtomicEdit=0; startPos:3775; endPos
IllegalStateException: Unfinished non-first replace - error during view repla...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P1 (vote)
: 7.0
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
: 70_HR_FIX
: 197082 197255 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-25 10:25 UTC by jocke
Modified: 2011-04-08 07:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.13 KB, text/plain)
2011-03-25 10:25 UTC, jocke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jocke 2011-03-25 10:25:15 UTC
This bug was originally marked as duplicate of bug 195432, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201103240400)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
jocke: editing java file

jocke: ...




Stacktrace: 
java.lang.IllegalStateException: Unfinished non-first replace - error during view replacement: view:
DV@6c0f0f14#225:<3775,17506>, WxH:2156.0x3375.0; incomingMod=true; lengthyAtomicEdit=0; startPos:3775; endPos:17506
    [  0]: PV@43b229e4#3:<3775,3841> Y=0.0(R0.0), WxH:462.0x15.0
        [0]: HV@447e7432#0:<3775,3777> X=0.0(R0.0) L=<NULL>
        [1]: HV@49fea1bf#0:<3777,3840> X=14.0(R14.0) L=<NULL>
        [2]: NV@6c2d288c#0:<3840,3841> X=455.0(R455.0)
    [  1]: PV@529b8418#11:<3841,3875> Y=15.0(R15.0), WxH:238.0x15.0
        [ 0]: HV@08c136d0#0:<3841,3843> X=0.0(R0.0) L=<NULL>
        [ 1]: HV@44f5962d#0:<3843,3850> X=14.0(R14.0) L=<NULL>
        [ 2]: HV@575687b9#0:<3850,3851> X=63.0(R63.0) L=<NULL>
        [ 3]: HV@71e8af7a#0:<3851,3855> X=70.0(R70.0) L=<NULL>
        [ 4]: HV@6358ad02#0:<3855,3856> X=98.0(R98.0) L=<NULL>
        [ 5]: HV@52c69142#0:<3856,3870> X=105.0(R105.0) L=<NULL>
        [ 6]: HV@6a6aae82#0:<3870,3871> X=203.0(R203.0) L=<NULL>
        [ 7]: HV@01e70f63#0:<3871,3872> X=210.0(R210.0
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createViews(ViewBuilder.java:342)
   at org.netbeans.modules.editor.lib2.view.ViewUpdates.buildViews(ViewUpdates.java:182)
   at org.netbeans.modules.editor.lib2.view.ViewUpdates.removeUpdate(ViewUpdates.java:478)
   at sun.reflect.GeneratedMethodAccessor253.invoke(GeneratedMethodAccessor253.java:0)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
Comment 1 jocke 2011-03-25 10:25:19 UTC
Created attachment 107275 [details]
stacktrace
Comment 2 Miloslav Metelka 2011-03-25 19:51:31 UTC
It's strange that the fix in issue 196734 did not turn off the view hierarchy updating prior receiving a removal.
Anyway I have made another fix that should prevent any updates to tooltip's view hierarchy. Also it should hopefully eliminate the other issue 197082 (or at least make a better info about what went wrong) so I make it a duplicate of this issue.

Btw don't you remember what were your last actions prior the exception? Were you manipulating code folds? Thanks.

http://hg.netbeans.org/jet-main/rev/d8c96efe77b0
Comment 3 Miloslav Metelka 2011-03-25 19:51:48 UTC
*** Bug 197082 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2011-03-28 08:47:01 UTC
Integrated into 'main-golden', will be available in build *201103280400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d8c96efe77b0
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #197083 - IllegalStateException: Unfinished non-first replace - error during view replacement: view: DV@6c0f0f14#225:<3775,17506>, WxH:2156.0x3375.0; incomingMod=true; lengthyAtomicEdit=0; startPos:3775; endPos - no updates to view hierarchy allowed in tooltip's editor pane for document modifications.
Comment 5 Miloslav Metelka 2011-03-30 07:11:28 UTC
I would like to integrate this into release70 branch.
Comment 6 Jaromir Uhrik 2011-03-30 12:26:14 UTC
Any hint how to reproduce? I have no idea what are steps to reproduce so that I am not able to verify. jocke, could you please verify?
Thanks.
Comment 7 jocke 2011-03-30 12:59:26 UTC
(In reply to comment #6)
> Any hint how to reproduce? I have no idea what are steps to reproduce so that I
> am not able to verify. jocke, could you please verify?
> Thanks.

No, I can't reproduce this now, I'm using Build 201103300400
Comment 8 jocke 2011-03-30 13:10:09 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Any hint how to reproduce? I have no idea what are steps to reproduce so that I
> > am not able to verify. jocke, could you please verify?
> > Thanks.
> 
> No, I can't reproduce this now, I'm using Build 201103300400

I can verify that this is fixed :)
Comment 9 Jan Lahoda 2011-03-30 13:12:19 UTC
I do not see any problem in the patch.
Comment 10 Miloslav Metelka 2011-03-30 16:41:57 UTC
In release70:
d8c96efe77b0 transplanted as 0317d3b70ecf
Comment 11 Miloslav Metelka 2011-03-31 16:34:53 UTC
*** Bug 197255 has been marked as a duplicate of this bug. ***
Comment 12 Jaromir Uhrik 2011-04-08 07:55:30 UTC
Marking as Verified based on the comments above and the fact that no regression has been found during testing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo