The name of JDK 7.0 language feature has changed from "Automatic Resource Management" to "try-with-resources". The hint should reflect this change.
The name of hint and its description has to be changed.
"Convert to Automatic Resource Management" changed into "Convert to try-with-resources"
"Converts try finally block to Automatic Resource Management" changed into "Converts try finally block to try-with-resources"
Fixed jet-main 9b10649a9bde
I agree with the patch.
This should be also transplanted:
(no need for review, IMO, as the patch only modifies tests)
Transplanted into release70 3f4c4d543ec5
Transplanted into release70 1ad0cb0d168c
Integrated into 'main-golden', will be available in build *201103280400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
User: Tomas Zezula <firstname.lastname@example.org>
Log: #196998:Rename Automatic Resource Management to try-with-resources
Reporter=Developer who fixed the issue - so I have checked only the change integration. Marking as Verified.