Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 196960 - Go to File is too slow to be usuable
Go to File is too slow to be usuable
Status: RESOLVED DUPLICATE of bug 195814
Product: editor
Classification: Unclassified
Component: Navigation
7.0
PC Windows 7
: P2 (vote)
: 7.0.1
Assigned To: Jan Becicka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-22 12:40 UTC by ritwikmitra
Modified: 2011-03-22 16:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ritwikmitra 2011-03-22 12:40:23 UTC
Hi,

For Java developers, the Go To File option is too slow to be of any use.

For Java classes, we can use Go To Type but for other file types, we need to use Go To File option only. Even on a small project, around 50-60 files, the go to file option is too slow to be of any use.

Specially, if a user mis-spells the name of the file, the response "No Files found" is too slow ~ takes nearly 20 seconds to report that the file does not exist.

Usually navigation is helpful even if you remember a part of the name. However, in Netbeans if you remember the name correctly (exactly) it is still usable but otherwise it is too slow to be of any use.

Comparing with other editors (Idea, Eclipse) which perform nearly same for both go to type and go to file / resource, it is sad to see Netbeans which has quite a few good features to miss out on such basic functionality.
Comment 1 Tomas Zezula 2011-03-22 16:52:58 UTC
Not a part of java.
In fact the GTF has 3 parts as described in issue #195814.
The index part based on parsing.api is fast. The problem is with the non indexed part (non source files) which are searched by fs crawling. See details in #195814.

*** This bug has been marked as a duplicate of bug 195814 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo