Bug 196948 - NullPointerException at javax.swing.DefaultRowSorter.convertRowIndexToModel
NullPointerException at javax.swing.DefaultRowSorter.convertRowIndexToModel
Status: RESOLVED FIXED
Product: third-party
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: TBD
Assigned To: _ rkubacki
issues@third-party
EXCEPTIONS_REPORT
:
: 197503 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-22 08:54 UTC by nuboat
Modified: 2011-06-03 08:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.42 KB, text/plain)
2011-03-22 08:55 UTC, nuboat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nuboat 2011-03-22 08:54:55 UTC
Build: NetBeans IDE 6.9.1 (Build 201011082200)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
nuboat: ADB Log




Stacktrace: 
java.lang.NullPointerException
   at javax.swing.DefaultRowSorter.convertRowIndexToModel(DefaultRowSorter.java:501)
   at javax.swing.JTable.convertRowIndexToModel(JTable.java:2611)
   at javax.swing.JTable.getValueAt(JTable.java:2686)
   at javax.swing.JTable.prepareRenderer(JTable.java:5703)
   at javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:2072)
   at javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:1974)
Comment 1 nuboat 2011-03-22 08:55:00 UTC
Created attachment 107177 [details]
stacktrace
Comment 2 Marian Mirilovic 2011-03-22 16:19:19 UTC
JDk problem ?
Comment 3 Marian Mirilovic 2011-04-07 07:48:49 UTC
*** Bug 197503 has been marked as a duplicate of this bug. ***
Comment 4 Antonin Nebuzelsky 2011-05-30 16:53:41 UTC
All related to an action "ADB Log" in thirdparty Android support. Reassigning.

JDK report which may help:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6582564
Comment 5 _ rkubacki 2011-06-03 08:56:24 UTC
http://kenai.com/projects/nbandroid/sources/mercurial/revision/408

It would be better to fix the cause in Swing. I wrapped the code to ignore the problem but this can cause a problem at a different place.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo