Bug 19691 - CVS: COMMIT_TEMPLATE_GETTER fails if user dir contains spaces.
CVS: COMMIT_TEMPLATE_GETTER fails if user dir contains spaces.
Status: CLOSED FIXED
Product: obsolete
Classification: Unclassified
Component: vcsgeneric
3.x
PC Windows ME/2000
: P3 (vote)
: -S1S-
Assigned To: Martin Entlicher
issues@obsolete
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 11:18 UTC by Jiri Kovalsky
Modified: 2003-07-01 13:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2002-01-23 11:18:22 UTC
RC2 build #200201230331 of NetBeans 3.3.1 on Windows 2000 with JDK 1.4b91

Description:
============
Auto pre-commit functionality does not work if user launches IDE with user direc-
tory that contains at least one space in its path. The result is that commit tem-
plate is not generated and commit message is set to single new line character.

Steps to reproduce:
===================
1. Launch IDE with -userdir "C:\Temporary folder\Test" switch.
2. Mount CVS filesystem using Command-line Client.
3. Modify some [Up-to-date] file so that it becomes [Locally Modified].
4. Right click this file and choose "CVS|Commit" popup menu item.
5. "Enter reason" textarea will be empty.
Comment 1 Jiri Kovalsky 2002-01-23 11:20:16 UTC
This is pure SPACE_IN_PATH problem that in this case concerns user
directory.
Comment 2 Martin Entlicher 2002-01-23 13:04:09 UTC
Well, the "wincat.bat", which is supplied as an editor to CVS contains
spaces in it's path. It's properly quoted for the shell, but CVS
probably interprets it in a bad way. I will try to experiment with the
quotation to find out whether there is some chance to get it to work.

If there is a bug in CVS executable (i.e. can not run editors which
have space in it's path), some workaround would have to be invented
(e.g. copy wincat.bat into the current folder each time pre-commit is
to be executed).
Comment 3 Martin Entlicher 2002-02-11 11:20:23 UTC
I didn't find any quotation combination, that would work. Even on
Unix, the editor command is not found when it contains spaces, I was
not able to find any suitable quotation. It seems, that cvs does not
work correctly whenever it's arguments contains spaces.

It seems, that the only possible workaround would be to detect whether
the path to wincat.bat contains spaces and if yes, copy wincat.bat to
the current working directory and remove it again after the command
finishes.

Hints and other solutions appreciated.
Comment 4 Martin Entlicher 2002-02-20 12:48:37 UTC
Fixed by copying wincat.bat into the current working directory when
the home directory contains spaces.
Fixed in dev build Feb 21.

Comment 5 Jiri Kovalsky 2002-03-08 15:21:57 UTC
Cool. Verified in development build #200203080100 of NetBeans 3.4.
Comment 6 Mark Dey 2002-07-11 00:52:01 UTC
This fix needs to be backported to the sierra branch where
SPACE_IN_PATH is a supported feature.
Comment 7 Milos Kleint 2002-07-12 14:13:34 UTC
closing since the bug is fixed in trunk, the SIERRA_FIX keyword is enough.
Comment 8 Jiri Kovalsky 2002-07-12 15:04:25 UTC
Sure. BTW, why did you Mark need it opened ?
Comment 9 Mark Dey 2002-07-12 16:24:58 UTC
I just wanted to make sure this appeared on the open bug list for 
Sierra. I was under the impression that this would not happen if the 
bug was marked FIXED, but Trung has since clarified that as long as 
the S1S4.1 target milestone is -not- selected, this will be flagged as 
open in that release (since the SIERRA_FIX keyword is set). Sorry for 
any confusion.
Comment 10 Martin Entlicher 2002-07-19 10:12:26 UTC
Fixed in the sierra branch.
Comment 11 Jiri Kovalsky 2002-09-05 10:50:34 UTC
Confirming as fixed in Sierra build #020902_1 of Sun ONE Studio 4
update 1.
Comment 12 Petr Pisl 2002-10-15 14:59:56 UTC
The bug is steal in realease notes.
Comment 13 Quality Engineering 2003-07-01 13:03:27 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo