Bug 196793 - Comment / uncomment region action
Comment / uncomment region action
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
7.0
All All
: P3 (vote)
: 8.0
Assigned To: Svata Dedic
issues@editor
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 00:41 UTC by chris4beta
Modified: 2016-07-07 07:28 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris4beta 2011-03-17 00:41:42 UTC
Take the following CSS:

#something{margin:10px;padding:5px}

In NetBeans 6.8, if I highlight "margin:10px;" and hit shift+ctrl+c, the above line would become:

#something{/*margin:10px;*/padding:5px}

This is the correct behavior. Instead, now this happens:

/*#something{margin:10px;padding:5px}*/

I only had "margin:10px;" selected, but it commented out the entire line.

Product Version = NetBeans IDE 7.0 Beta 2 (Build 201102140001)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_22
Runtime = Java HotSpot(TM) Client VM 17.1-b03
Comment 1 Marek Fukala 2011-11-01 15:51:11 UTC
CSL's ToggleBlockCommentAction issue
Comment 2 Svata Dedic 2012-04-16 13:27:43 UTC
I understand the request, but currently we do not have an action, which comments out the exactly selected portion of text. Comment* actions toggle comment on the rows at least partially spanned by the selection.

Changing to RFE - valid request, but was not intended to implement by CSL originally :)
Comment 3 Svata Dedic 2013-04-29 10:01:08 UTC
I'll use regular text' selection bk color to highlight fold with at least partially selected text.
Comment 4 Svata Dedic 2013-04-29 10:01:27 UTC
oops, wrong issue, ignore please :)
Comment 5 Martin Balin 2016-07-07 07:28:25 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo