Bug 196776 - Search button doesn't work
Search button doesn't work
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Actions
7.0
All All
: P1 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
: 70_HR_FIX, REGRESSION, VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-16 13:46 UTC by michal.owsiak
Modified: 2011-03-25 12:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
search_button_doesnt_work (870.46 KB, video/quicktime)
2011-03-16 13:47 UTC, michal.owsiak
Details
Test and unfinished fix (6.01 KB, patch)
2011-03-19 17:28 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description michal.owsiak 2011-03-16 13:46:34 UTC
see attached movie.

Instead, if you press next previous occurrence, you can type in search text - but only once (at first time). Then, it is not possible to change text you are looking for.
Comment 1 michal.owsiak 2011-03-16 13:47:22 UTC
Created attachment 107050 [details]
search_button_doesnt_work
Comment 2 Tomas Hurka 2011-03-16 19:04:36 UTC
 To get access to Find dialog, use command-F shortcut or from menu Edit->Find.
Comment 3 Tomas Hurka 2011-03-16 19:09:43 UTC
It works fine in 6.9.1
Comment 4 michal.owsiak 2011-03-16 20:57:54 UTC
I can confirm, that Command + F works with Mac OS X - thus, this error is not a stopper. However, why pressing magnification glass doesn't open the dialog?
Comment 5 Tomas Hurka 2011-03-17 12:48:40 UTC
The following is happening:
1) user clicks on 'Find' button
2) setPressed(true) is invoked on the DefaultButtonModel
3) setEnabled(false) is invoked on the DefaultButtonModel because FindAction was disabled due to focus change to 'Find' button
5) user releases mouse
4) setPressed(false) is invoked on the DefaultButtonModel
5) setPressed() does nothing since setEnabled() false cleared ARMED and PRESSED state.


It looks like regression in openide/action. 
Reassigning.
Comment 6 Jaroslav Tulach 2011-03-19 17:28:06 UTC
Created attachment 107122 [details]
Test and unfinished fix
Comment 7 Jaroslav Tulach 2011-03-21 17:56:17 UTC
One fix in the infrastructure, one in the profiler:

ergonomics#1da9e019a439
ergonomics#e6f2fe03f69a

Please verify.
Comment 8 Tomas Hurka 2011-03-22 08:43:29 UTC
The similar code to ergonomics#e6f2fe03f69a  is used on several other places. These need to fixed too.
Comment 9 Tomas Hurka 2011-03-22 13:10:16 UTC
Fixed in profiler-main

changeset:   191326:683862855e9a
user:        Tomas Hurka <thurka@netbeans.org>
date:        Tue Mar 22 11:32:33 2011 +0100
summary:     additional bugfix #196776: connect FindAction with TopComponent's lookup via ContextAwareAction
Comment 10 Quality Engineering 2011-03-23 09:59:49 UTC
Integrated into 'main-golden', will be available in build *201103230400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1da9e019a439
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #196776: Ignore changes of focus to button with ContextAwareAction
Comment 11 Jaroslav Tulach 2011-03-23 14:35:40 UTC
Merged as releases#6f0fb8e64568
Comment 12 Tomas Danek 2011-03-25 12:12:47 UTC
i cannot reproduce this case in profiler in latest 7.0rc1 build - verified.

Product Version: NetBeans IDE 7.0 RC1 (Build 201103250000)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02
System: Linux version 2.6.35-28-generic running on amd64; ANSI_X3.4-1968; en_US (nb)
Userdir: /home/tomas/.netbeans/7.0rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo