Bug 196651 - Code folding icons next to line numbers do not get redrawn properly after expanding a parent item
Code folding icons next to line numbers do not get redrawn properly after exp...
Status: RESOLVED DUPLICATE of bug 196281
Product: editor
Classification: Unclassified
Component: Code folding
7.0
PC Windows 7
: P3 (vote)
: 7.0
Assigned To: Petr Pisl
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-13 22:45 UTC by maghiel
Modified: 2011-04-13 09:02 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maghiel 2011-03-13 22:45:18 UTC
[ BUILD # : 201103120000 ]
[ JDK VERSION : 1.6.23 ]

Using a new PHP Web Page
(File > New > PHP > PHP Web Page)

Recurrent code folding.
* Collapse several code folds.
* Collapse a code fold containing all of them.
* Expand that code fold back.
* Expand all other code folds.

The expand icon next to the linenumbers is not redrawn for the second node
after expanding the first node.
Comment 1 Sc0tTyXL 2011-03-14 22:51:51 UTC
I had already uploaded my screenshot to tinypic for my sanity test:
http://i52.tinypic.com/orms7s.png

When i closed the file ( without saving ) and reopened it, i was unable to reproduce it, sounds to me that it's a cache bug or something.

jdk 1.6.24 with rc1 on win7 x64
Comment 2 Sc0tTyXL 2011-03-14 23:03:29 UTC
Whoops, i really need to get some sleep.

The previous screenshot is for another bug.

http://i53.tinypic.com/257naxy.png is the correct screenshot
Comment 3 Petr Pisl 2011-03-15 09:10:54 UTC
When make a change in the file, the code folding is corrected?
Comment 4 Petr Pisl 2011-03-15 12:37:59 UTC
I can not reproduce it somehow. Can you always reproduce it?

Anyway the priority is not P2. I'm downgrading it to P3
Comment 5 Vladimir Riha 2011-03-16 11:56:29 UTC
Could it be duplicate of issue #196281? If not, If guess that my comments to issue #196281 belongs here
Comment 6 maghiel 2011-04-13 01:42:00 UTC
*** Bug 197415 has been marked as a duplicate of this bug. ***
Comment 7 Marian Mirilovic 2011-04-13 09:02:28 UTC
(In reply to comment #5)
> Could it be duplicate of issue #196281? If not, If guess that my comments to
> issue #196281 belongs here

I think so ...

*** This bug has been marked as a duplicate of bug 196281 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo