Bug 196636 - "cd /path/to/buid_dir" is not executed at assembling of project.
"cd /path/to/buid_dir" is not executed at assembling of project.
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.0
PC Linux
: P1 (vote)
: 7.0
Assigned To: Vladimir Kvashin
issues@cnd
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-13 07:34 UTC by yuriy_lalym
Modified: 2011-03-18 14:51 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yuriy_lalym 2011-03-13 07:34:49 UTC
Import a qmake project:                         /path/to/my_project
Specify the directory for the project assembly: /path/to/my_project/build
The auxiliary NetBeans directory:               /path/to/NetBeansProj
The auxiliary project directory:                /path/to/NetBeansProj/my_project_1

The assembly is carried out /path/to/NetBeansProj/my_project_1, not in /path/to/my_project/build.

In NetBeans from March, 8th of the given problem wasn't, from March, 12th (NetBeans Build 201103120400) - is.
Comment 1 Alexander Simon 2011-03-13 09:20:01 UTC
P1 because build action does not work.
Simplest way to reproduce problem:
- download qt project (for example http://personal.inet.fi/koti/rkauppila/projects/life/qlife-qt4-0.9.tar.gz)
- create project with existing code: custom, select "Run configure script in subfolder", select project location different from project sources
Project successfully created.
Project cannot be build.
Comment 2 Alexander Simon 2011-03-13 10:16:08 UTC
It seems bug is result of change set:
http://hg.netbeans.org/cnd-main?cmd=changeset;node=6a4ecd5275a7
Comment 3 Vladimir Kvashin 2011-03-13 16:02:37 UTC
It's even easier to reproduce, just create any project from existing code, use custom mode and place nbproject separately, not inside the directory with project code.
Comment 4 Vladimir Kvashin 2011-03-13 19:31:37 UTC
fixed in cnd-main
http://hg.netbeans.org/cnd-main/rev/a728e7426252
Comment 5 Quality Engineering 2011-03-14 09:37:13 UTC
Integrated into 'main-golden', will be available in build *201103140400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a728e7426252
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #196636 - "cd /path/to/buid_dir" is not executed at assembling of project
Comment 6 Vladimir Kvashin 2011-03-15 14:14:23 UTC
QA, could you verify please
Comment 7 soldatov 2011-03-15 14:49:31 UTC
Verified in NetBeans IDE Dev (Build cnd-main-5537-on-110315)
Comment 8 Vladimir Voskresensky 2011-03-15 15:56:51 UTC
fix is reviewed. It fixes introduced regression
Comment 9 Alexander Pepin 2011-03-15 16:44:30 UTC
verified in dev build #4974
Comment 10 Vladimir Kvashin 2011-03-16 18:44:44 UTC
Changesets integrated to release70:
http://hg.netbeans.org/releases/rev/f755bcd7ac70
Comment 11 Alexander Pepin 2011-03-18 14:51:53 UTC
verified in RC1 build 20110317


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo