Bug 196580 - Broken code model in Subprojects sample
Broken code model in Subprojects sample
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
7.0
PC Windows 7 x64
: P1 (vote)
: 7.0
Assigned To: Vladimir Voskresensky
issues@cnd
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-11 11:57 UTC by Alexander Pepin
Modified: 2011-03-18 14:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2011-03-11 11:57:22 UTC
Steps to reproduce:
- create Subprojects sample application
- restart IDE
- open main.cc
- try to navigate to "hello" functions
Result: Some functions can not be open or "std" is marked as undefined. Classes view do not show all required projects.
Comment 1 Vladimir Voskresensky 2011-03-11 13:51:57 UTC
I can not reproduce it on my systems, but I've seen it on Windows 7
Comment 2 Alexander Pepin 2011-03-11 18:35:21 UTC
It seems that restart IDE (RC1) with opened projects also breaks code model on all platforms. Now I can see it on my Linux desktop (no system includes for Quote).
Comment 3 soldatov 2011-03-11 20:48:30 UTC
I can't reproduce described problem on my Windows XP machine, but I see interesting behaviour.
Scenario:
- Create Subproject demo
- Open main.cc file
- Activate Classes tab
- Close IDE
- Start IDE

If I activate main.cc file and click into it for ~1 second, then sometimes some projects doesn't appear in Classes tab. Sometimes projects appears if I close and open Classes tab. Sometimes projects doesn't appear and hyperlinks works wrongly in this case.
Comment 4 Quality Engineering 2011-03-12 09:44:47 UTC
Integrated into 'main-golden', will be available in build *201103120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/111944bdc605
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #196580 -  Broken code model in Subprojects sample
-- diagnostic to find root cause
Comment 5 Vladimir Voskresensky 2011-03-13 20:23:34 UTC
trace:
http://hg.netbeans.org/cnd-main?cmd=changeset;node=111944bdc605
http://hg.netbeans.org/cnd-main?cmd=changeset;node=e540189c1124
http://hg.netbeans.org/cnd-main?cmd=changeset;node=dd0b4bba8743
finally fix:
http://hg.netbeans.org/cnd-main?cmd=changeset;node=4a8b54940d89

-- use one worker thread to manage opening/closing tasks, otherwise due to concurrency 3 opened projects event is delivered after already handled event of 5 opened projects and 2 projects are asked to be closed
Comment 6 Vladimir Voskresensky 2011-03-13 20:26:57 UTC
QA, please, verify
Alexander Simon, please, review
Comment 7 Quality Engineering 2011-03-14 09:37:23 UTC
Integrated into 'main-golden', will be available in build *201103140400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e540189c1124
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing ##196580 -  Broken code model in Subprojects sample
-- diagnostic to find root cause
Comment 8 Alexander Simon 2011-03-14 09:59:00 UTC
Fix safe and fixes races at starting IDE time.
Comment 9 Alexander Pepin 2011-03-14 11:30:30 UTC
Can not reproduce the problem in dev build any more on both Windows and Linux. Please push the fix into RC branch.
Comment 11 Alexander Pepin 2011-03-18 14:54:35 UTC
verified in RC1 build 20110317


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo