Bug 196549 - [70cat] IllegalStateException: matchOffset=52628 > docViewEndOffset=52620 docView: DV@0154c674#16:<51926,52620>, WxH:776.0x272.0; incomingMod=true; lengthyAtomicEdit=0 [ 0]: PV@01b57294#13:<51926,51991> Y
[70cat] IllegalStateException: matchOffset=52628 > docViewEndOffset=52620 doc...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P1 (vote)
: 7.0
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
: 70_HR_FIX
: 196615 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-10 15:03 UTC by alied
Modified: 2011-03-16 11:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.99 KB, text/plain)
2011-03-10 15:03 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2011-03-10 15:03:08 UTC
This bug was originally marked as duplicate of bug 191620, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201103100400)
VM: Java HotSpot(TM) Client VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Windows XP

User Comments:
alied: While editing.
Pasteing and deleting some characters




Stacktrace: 
java.lang.IllegalStateException: matchOffset=52628 > docViewEndOffset=52620
docView:
DV@0154c674#16:<51926,52620>, WxH:776.0x272.0; incomingMod=true; lengthyAtomicEdit=0
    [ 0]: PV@01b57294#13:<51926,51991> Y=0.0(R0.0), WxH:520.0x17.0
        [ 0]: HV@01d06699#0:<51926,51938> X=0.0(R0.0) L=[0#12]<0>;x=0.0;fC=<NULL>;bC=<NULL>
        [ 1]: HV@00ffeeb8#0:<51938,51944> X=96.0(R96.0) L=[1#12]<12>;x=96.0;fC=<NULL>;bC=<NULL>
        [ 2]: HV@0091891c#0:<51944,51945> X=144.0(R144.0) L=[2#12]<18>;x=144.0;fC=<NULL>;bC=<NULL>
        [ 3]: HV@00c0b9aa#0:<51945,51965> X=152.0(R152.0) L=[3#12]<19>;x=152.0;fC=<NULL>;bC=<NULL>
        [ 4]: HV@00dd7fad#0:<51965,51966> X=312.0(R312.0) L=[4#12]<39>;x=312.0;fC=<NULL>;bC=<NULL>
        ...
        [ 8]: HV@01e96889#0:<51986,51987> X=480.0(R480.0) L=[8#12]<60>;x=480.0;fC=<NULL>;bC=<NULL>
        [ 9]: HV@00ce32be#0:<51987,51988> X=488.0(R488.0) L=[9#12]<61>;x=488.0;fC=<NULL>;bC=<NULL>
        [10]: HV@016594e1#0:<51988,51989> X=496.0(R496.0) L=[10#12]<62>;x=496.0;fC=<NULL>;bC
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createNextView(ViewBuilder.java:389)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createViews(ViewBuilder.java:343)
   at org.netbeans.modules.editor.lib2.view.ViewUpdates.buildViews(ViewUpdates.java:180)
   at org.netbeans.modules.editor.lib2.view.ViewUpdates.insertUpdate(ViewUpdates.java:367)
   at sun.reflect.GeneratedMethodAccessor58.invoke(GeneratedMethodAccessor58.java:0)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Comment 1 alied 2011-03-10 15:03:12 UTC
Created attachment 106879 [details]
stacktrace
Comment 2 Miloslav Metelka 2011-03-10 16:56:15 UTC
Unfortunately this is from a build with issue 195432 :( so another fix is necessary.
Comment 3 Miloslav Metelka 2011-03-11 19:41:16 UTC
http://hg.netbeans.org/jet-main/rev/3204ee8ed67e

I've made a patch for a case when a document listener would fail with a runtime exception. Then the view hierarchy updating would fail exactly in a way the exception looks in this case. Patch improves robustness of a document listeners firing.
Unfortunately I'm unable to reproduce the exception during the regular editing.

alied, could you please test a nightly build with the exception integrated whether you can still reproduce the problem? Thanks. (A note about a build containing the patch will be added to the issue soon.)
Comment 4 alied 2011-03-11 22:55:04 UTC
ok, just tell me when the build is ready and I will download it. I am not quite sure how to trigger the error, but I'll try it.
in recent builds i've been getting these exceptions, and always before reporting them, install a new build. The first time was with a old build which updated some editor-related modules.
Comment 5 Marian Mirilovic 2011-03-12 08:52:50 UTC

*** This bug has been marked as a duplicate of bug 196615 ***
Comment 6 Quality Engineering 2011-03-12 09:44:26 UTC
Integrated into 'main-golden', will be available in build *201103120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3204ee8ed67e
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #196549 - [70cat] IllegalStateException: matchOffset=52628 > docViewEndOffset=52620 docView: DV@0154c674#16:<51926,52620>, WxH:776.0x272.0; incomingMod=true; lengthyAtomicEdit=0 [ 0]: PV@01b57294#13:<51926,51991> - improved robustness of document listeners firing.
Comment 7 Miloslav Metelka 2011-03-14 09:57:04 UTC
alied: please download build *201103120400* on http://bits.netbeans.org/dev/nightly/ and check whether the problem occurs or not.
I know that the issue is random but if it won't occur for certain time then we can become confident that the problem is fixed. Thanks.
Comment 8 Jan Lahoda 2011-03-15 12:34:34 UTC
Seems fine to me.
Comment 9 Vladimir Riha 2011-03-15 13:01:14 UTC
I was trying to reproduce it and without any success, so for me is verified.
Comment 10 alied 2011-03-15 13:36:07 UTC
So far so good:
Product Version: NetBeans IDE Dev (Build 201103140400)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Windows XP version 5.1 running on x86;
Comment 11 Miloslav Metelka 2011-03-15 13:38:09 UTC
Marking as P1 in order to integrate into release70.
Comment 12 Miloslav Metelka 2011-03-15 14:11:42 UTC
*** Bug 196615 has been marked as a duplicate of this bug. ***
Comment 13 Miloslav Metelka 2011-03-16 11:28:20 UTC
transplanted into release70: 3204ee8ed67e transplanted as 22d0849018ff


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo