Bug 196493 - OOM in org.netbeans.modules.php.editor.indent.FormatVisitor.addFormatToken
OOM in org.netbeans.modules.php.editor.indent.FormatVisitor.addFormatToken
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
7.0
PC Mac OS X
: P2 (vote)
: 7.0
Assigned To: Petr Pisl
issues@php
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 13:44 UTC by Marek Fukala
Modified: 2011-03-25 06:03 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2011-03-09 13:44:29 UTC
http://statistics.netbeans.org/exceptions/exception.do?id=460886

and many more 6.9.* reports from http://statistics.netbeans.org/exceptions/detail.do?id=153648

shows an OOM from the method above. 

Petr Pisl has already addressed the issue by throwing AssertionError when a cycle in the method happens but the OOM may still happen in the production build with assertions disabled
Comment 1 Petr Pisl 2011-03-09 14:00:39 UTC
Fixed on my disk, when the repository will be open, I will commit to the web-main.
Comment 2 Petr Pisl 2011-03-10 12:39:59 UTC
The fix
http://hg.netbeans.org/web-main/rev/092e8aad777c
Comment 3 Petr Pisl 2011-03-10 13:01:50 UTC
I don't know how the QA could verify the fix, because the cases where it can happen should be already fixed. This is a prevention before OOM if there will be a case (in the code) that is not covered yet.
Comment 4 Marian Mirilovic 2011-03-10 21:12:20 UTC
(In reply to comment #3)
> I don't know how the QA could verify the fix, because the cases where it can
> happen should be already fixed. This is a prevention before OOM if there will
> be a case (in the code) that is not covered yet.

Ok integrate this into 7.0 and we'll do sanity test to try to catch regressions.
(Lada, please do sanity test once this fix is integrated into 7.0 RC1, thanks in advance)
Comment 5 Vladimir Riha 2011-03-10 21:29:36 UTC
Sure, I'll test it once it will be in 7.0 RC1
Comment 6 Quality Engineering 2011-03-11 09:38:48 UTC
Integrated into 'main-golden', will be available in build *201103110400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/092e8aad777c
User: Petr Pisl <ppisl@netbeans.org>
Log: #196493 - OOM in org.netbeans.modules.php.editor.indent.FormatVisitor.addFormatToken
Comment 7 Vladimir Riha 2011-03-14 09:16:22 UTC
Problem didn't appear in sanity test, verified

Product Version: NetBeans IDE Dev (Build 201103130400)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 8 Petr Pisl 2011-03-14 20:16:26 UTC
The patch transplanted into releases repository, release70 branch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo