Bug 196486 - java.lang.IllegalStateException if IDE is closed
java.lang.IllegalStateException if IDE is closed
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.0
All All
: P1 (vote)
: 7.0
Assigned To: Alexander Simon
issues@cnd
: 70_HR_FIX
: 196095 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 12:27 UTC by soldatov
Modified: 2011-03-25 06:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
full log (67.91 KB, text/plain)
2011-03-09 12:28 UTC, soldatov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2011-03-09 12:27:44 UTC
Scenario:
- Create Quote project
- Wait parser is finished
- Click on [x] button in right top corner (close IDE)
- Check log
===>
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
	at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1904)
	at org.openide.util.Mutex.doWrapperAccess(Mutex.java:1326)
	at org.openide.util.Mutex.readAccess(Mutex.java:354)
	at org.openide.explorer.view.TreeView$TreePropertyListener.propertyChange(TreeView.java:1286)
	at org.openide.util.WeakListenerImpl$PropertyChange.propertyChange(WeakListenerImpl.java:196)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at org.openide.explorer.ExplorerManager$2.run(ExplorerManager.java:868)
	at org.openide.util.Mutex.doEvent(Mutex.java:1341)
	at org.openide.util.Mutex.readAccess(Mutex.java:348)
	at org.openide.explorer.ExplorerManager.fireInAWT(ExplorerManager.java:865)
	at org.openide.explorer.ExplorerManager$Listener.propertyChange(ExplorerManager.java:935)
Caused: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor35.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:459)
Caused: java.lang.reflect.UndeclaredThrowableException
	at $Proxy8.propertyChange(Unknown Source)
	at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1271)
	at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1194)
	at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1175)
	at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1271)
	at org.openide.nodes.Node.fireDisplayNameChange(Node.java:1065)
	at org.openide.nodes.AbstractNode.setName(AbstractNode.java:239)
	at org.netbeans.modules.cnd.makeproject.ui.MakeLogicalViewRootNode.propertyChange(MakeLogicalViewRootNode.java:274)
	at org.openide.util.WeakListenerImpl$PropertyChange.propertyChange(WeakListenerImpl.java:196)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at org.netbeans.modules.cnd.makeproject.MakeProject$Info.firePropertyChange(MakeProject.java:889)
	at org.netbeans.modules.cnd.makeproject.MakeProject.configurationXmlChanged(MakeProject.java:354)
[catch] at org.netbeans.spi.project.support.ant.AntProjectHelper$3.run(AntProjectHelper.java:502)
	at org.netbeans.spi.project.support.ant.AntProjectHelper$3.run(AntProjectHelper.java:497)
	at org.openide.util.Mutex.readAccess(Mutex.java:288)
	at org.netbeans.spi.project.support.ant.AntProjectHelper.fireChange(AntProjectHelper.java:497)
	at org.netbeans.spi.project.support.ant.AntProjectHelper.modifying(AntProjectHelper.java:523)
	at org.netbeans.spi.project.support.ant.AntProjectHelper.access$900(AntProjectHelper.java:110)
	at org.netbeans.spi.project.support.ant.AntProjectHelper$10.run(AntProjectHelper.java:964)
	at org.netbeans.spi.project.support.ant.AntProjectHelper$10.run(AntProjectHelper.java:937)
Comment 1 soldatov 2011-03-09 12:28:23 UTC
Created attachment 106852 [details]
full log
Comment 2 Alexander Simon 2011-03-09 18:58:58 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/b39bbe05f3d6
Comment 3 Alexander Simon 2011-03-09 18:59:18 UTC
QA, please, verify fix
Comment 4 Thomas Preisler 2011-03-10 02:24:36 UTC
*** Bug 196095 has been marked as a duplicate of this bug. ***
Comment 5 Quality Engineering 2011-03-10 09:33:57 UTC
Integrated into 'main-golden', will be available in build *201103100400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b39bbe05f3d6
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #196486 java.lang.IllegalStateException if IDE is closed
Comment 6 soldatov 2011-03-11 09:10:12 UTC
NetBeans IDE Dev (Build 201103110400)
verified this and scenario from issue 196095
Comment 7 Alexander Simon 2011-03-11 11:40:55 UTC
Vladimir V, please, review fix.
Comment 8 Vladimir Voskresensky 2011-03-11 13:10:54 UTC
fix is OK and it also fixes regression mentioned in issue #196095
Comment 9 Alexander Pepin 2011-03-11 13:40:45 UTC
Should be P1.
Comment 10 Alexander Simon 2011-03-11 21:13:37 UTC
fixed in release70:
http://hg.netbeans.org/releases/rev/29853394c3ed
Comment 11 soldatov 2011-03-18 11:50:43 UTC
Verified in NetBeans IDE 7.0 RC1 (Build 201103180000)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo