Bug 196303 - Can not debug full remote project
Can not debug full remote project
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0
PC All
: P1 (vote)
: 7.0
Assigned To: Egor Ushakov
issues@cnd
FULL_REMOTE
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-04 14:22 UTC by Alexander Pepin
Modified: 2011-03-17 16:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Fix prototype (2.38 KB, patch)
2011-03-05 21:41 UTC, Vladimir Kvashin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2011-03-04 14:22:11 UTC
Prerequisite - create a makefile based project on some Solaris host using GNU tool collection

Steps to reproduce:
- add the remote host
- import the project
- do step into
Result: "Starting gdb debugger" progress dialog appears and never finishes.

Debugger console gives:
/bin/sh[2]: cd: /export/hudson/home/.netbeans/remote/nyx-intel3/asus_laptop-Windows-x86_64/C/Users/ap153252/Documents/NetBeansProjects/test_io-shadow-1: [No such file or directory]
Comment 1 Vladimir Kvashin 2011-03-05 00:02:57 UTC
http://hg.netbeans.org/cnd-main/rev/73fb72488adb
Comment 2 Alexander Pepin 2011-03-05 13:58:04 UTC
I still can not debug in build 4882 from elif.
Comment 3 Vladimir Kvashin 2011-03-05 17:46:27 UTC
As I understand, the message mentioned in initial description isn't shown any more, right?

To me, debugger works, however t goes into disassembly instead of C/C++ code.

What are exact problems you experience? Is there anything in IDE log?
Comment 4 Alexander Pepin 2011-03-05 19:21:59 UTC
For me nothing changed. Start debugger dialog does not disappears and gdb console shows
/bin/sh[2]: cd: C:\Users\ap153252\Documents\NetBeansProjects\test_io_shadow: [No such file or directory]
Comment 5 Alexander Pepin 2011-03-05 19:27:56 UTC
Please note that all described above is about Windows. On Linux Start debugger dialog disappears but "Current PC" cursor does not appear in the source file.
Comment 6 Vladimir Kvashin 2011-03-05 19:58:10 UTC
Thanks for your comments. I now have a bit different although similar situation
(on Windows); hope to fix soon.
Comment 7 Vladimir Kvashin 2011-03-05 21:41:04 UTC
Created attachment 106754 [details]
Fix prototype

The root cause understood; attaching a fix prototype (going to improve it, place to the proper place and then push)
Comment 8 Quality Engineering 2011-03-06 05:40:11 UTC
Integrated into 'main-golden', will be available in build *201103060000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/73fb72488adb
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #196303 (Can not debug full remote project) and similar issues
Comment 9 Leonid Lenyashin 2011-03-07 11:34:38 UTC
I believe it is a showstopper. Debugging is the primary use case for full remote users.
Comment 10 Vladimir Kvashin 2011-03-09 00:25:51 UTC
fixed:
http://hg.netbeans.org/cnd-main/rev/e1e7007c4cbd
Comment 11 Alexander Pepin 2011-03-09 18:46:22 UTC
There is still a problem with debugging (on both Linux and Windows). The source file is not brought up automatically when PB is hit or "Step into project" is done. Also there is a problem with displaying BP annotations in the editor.
Comment 12 Leonid Lenyashin 2011-03-10 08:57:34 UTC
Egor, please help with this one.
Comment 13 Quality Engineering 2011-03-10 09:34:29 UTC
Integrated into 'main-golden', will be available in build *201103100400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e1e7007c4cbd
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #196303 - Can not debug full remote project
Comment 15 Quality Engineering 2011-03-11 09:38:37 UTC
Integrated into 'main-golden', will be available in build *201103110400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6487a4a9e67b
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing #196303 - Can not debug full remote project
Comment 16 Quality Engineering 2011-03-12 09:42:44 UTC
Integrated into 'main-golden', will be available in build *201103120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9262463ea4d2
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing #196303 Can not debug full remote project
Comment 17 Alexander Pepin 2011-03-14 14:43:02 UTC
verified in dev build #4962
Comment 18 Alexander Simon 2011-03-16 13:54:49 UTC
Fix right and safe.
Comment 20 Quality Engineering 2011-03-17 09:52:36 UTC
Integrated into 'main-golden', will be available in build *201103170400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/bdfdb89cdc85
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: additional fixes for #196542 - Can not run imported managed project, #196303 - Can not debug full remote project
Comment 21 Alexander Pepin 2011-03-17 16:49:39 UTC
verified in RC1 build 20110317


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo