Bug 196263 - Netbeans is waiting for connection (xdebug)
Netbeans is waiting for connection (xdebug)
Status: RESOLVED INCOMPLETE
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Linux
: P3 with 1 vote (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-03 21:11 UTC by naitsirch
Modified: 2012-04-05 08:15 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description naitsirch 2011-03-03 21:11:37 UTC
Hi,
I want to use Netbeans 6.9.1 with xdebug 2.1.0 on Linux version 2.6.32-5-486 (Debian 2.6.32-30). PHP and xdebug is both installed from Debian packages.

But when I start the debugging, the browser opens the page without any breaks and Netbeans says: "Waiting for Connection (netbeans-xdebug)" and nothing happens.

My xdebug.ini:
zend_extension=/usr/lib/php5/20090626+lfs/xdebug.so
xdebug.remote_enable=1
xdebug.remote_connect_back=1
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_handler="dbgp"
xdebug.remote_mode="req"
xdebug.remote_log="/etc/php5/xdebug.log"
xdebug.auto_trace=off
xdebug.default_enable=on

phpinfo() says
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans

And in the xdebug part of the phpinfo everything is correctly listed up.

I have tested xdebug with the script on this page:
http://blogs.sun.com/netbeansphp/entry/howto_check_xdebug_installation
The result was something like: "connection established: Resource id #5"

So I think xdebug works correctly.

Do you need any more information?
Comment 1 Aldert 2011-03-31 20:05:22 UTC
Installed Ubuntu 10.10
Via Applications installed Netbeans and php-xdebug

1. Create new PHP application with phpinfo(); in the index.php
2. Run the project, you can see xdebug is properly installed and running
3. Debug the project, all good and running OK

4. Add sources of an existing PHP (earlier created) in a folder on the same level as the new created php application above
5. In netbeans add a new project and choose existing sources.
6. Select the folder of the existing source
7. Debug the project, NOT OK, debugger is waiting and cannot connect!!

I see that there are lots of questions on the internet which are not answered. I cannot explain either why the existing project is not running but the new project is.

I included the source code of teh existing code. Once I copied teh existing code to the code of the new project it was running.

It cannot be a rights issue, I have set all to chmod 777 *.
Comment 2 Aldert 2011-03-31 20:15:51 UTC
I could not attach a tar file withthe source, unfortunately..
Comment 3 naitsirch 2011-04-19 10:15:32 UTC
Hi. In my case the debuging does not work with a new project, too.
I still have no solution :-(
Comment 4 Tomas Mysik 2011-06-03 10:23:03 UTC
Batch reassigning.
Comment 5 Tomas Mysik 2011-06-09 13:21:08 UTC
Reassigning to the module owner.
Comment 6 OndrejBrejla 2011-07-25 15:25:12 UTC
I tried exactly the same settings as you have (naitsirch), but I can't reproduce it. After cca 2 secs "Waiting for..." disappears and debug sesion starts. I really don't know what to advise you...
Comment 7 naitsirch 2011-08-10 14:25:49 UTC
Strange... okay, what does happen if I start debugging? Does NetBeans start listening on a port or how does it work?
Comment 8 naitsirch 2011-08-23 06:25:19 UTC
I found the solution of the problem. Netbeans had neither connection to the internet nor to the LAN. It has the same reason like in Bug #198613, which was committed by me, too.

But when I added this option "-J-Djava.net.preferIPv4Stack=true" to the netbeans.conf, the whole problem was resolved!

Here's the full line in the config file:
netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Djava.net.preferIPv4Stack=true"

But in my opinion, netbeans should check if there is a network connection and if not, it should try to connect to the network via IPv4, or is it not possible?
Comment 9 Ondrej Brejla 2012-04-05 07:38:51 UTC
Thanks for your evaluation. I think that this should be fixed in some higher NetBeans infrastructure if it affects all NetBeans modules. Thanks.
Comment 10 Ondrej Brejla 2012-04-05 08:15:56 UTC
But I'm afraid, that we can't do anything with that...it seems that Java socket creates ipv6 socket everytime if it's possible, unless you set that property you described.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo