Bug 196246 - Wrong version SwingX in ubuntu package
Wrong version SwingX in ubuntu package
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Debian
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@installer
: NO70, NO701
Depends on:
Blocks: 191325
  Show dependency treegraph
 
Reported: 2011-03-03 16:51 UTC by Jiri Rechtacek
Modified: 2011-05-26 11:00 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2011-03-03 16:51:28 UTC
Ubuntu 10.x packages contains NetBeans 6.9 with wrong link to SwingX library. There is SwingX 0.9.2 in Ubuntu packages but NetBeans requires SwingX 0.9.5 only. It makes unusable DB tooling in NetBeans - issue 191325.
Comment 1 Yulia Novozhilova 2011-04-27 09:53:06 UTC
It is not easy to fix this in Ubuntu 10.x because of the Ubuntu release policies. The package libswingx-java should be updated to 0.9.5 first and then netbeans package can be fixed. But after Ubuntu is  released it is prohibited to update to a new source version for the release, so it is better to fix this manually in your installation. 
It is possible to fix this in dev version (currently "natty").
Anyway there is a workaround: you can download the bits of swingx-0.9.5 and put them into netbeans installation folder instead of the one version 0.9.2. So I suppose it is P2.
Comment 2 Antonin Nebuzelsky 2011-05-19 13:39:34 UTC
Will be fixed for 6.9 Ubuntu packages by publishing the swingx wrapper module as an update with increased spec version but identical content of the module, on Ubuntu specific 6.9 UC.
Comment 3 Jiri Rechtacek 2011-05-26 11:00:45 UTC
The patch for NB6.9 on Ubuntu will be instantly publish on UC , use Help|Check for Updates or wait a period for automatically checking for updates.
For download newer release NB7.0 and other use http://netbeans.org/downloads/index.html Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo