Bug 196233 - local history lost focus
local history lost focus
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
7.0
PC Linux
: P3 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-03 14:46 UTC by holub
Modified: 2011-03-09 05:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description holub 2011-03-03 14:46:05 UTC
* open file local history
* select any version of file
* minimize/maximize history window

the history window lost focus of element and clear preview

Product Version = NetBeans IDE 7.0 Beta 2 (Build 201102140001)
Operating System = Linux version 2.6.37-2-686-bigmem running on i386
Java; VM; Vendor = 1.6.0_24
Runtime = Java HotSpot(TM) Client VM 19.1-b02
Comment 1 Tomas Stupka 2011-03-03 20:34:59 UTC
the same also for other TC with outlineview - e.g diffview in hg searchhistory
reassigning for further evaluation or advice what to do to preserve the selection
Comment 2 Martin Entlicher 2011-03-07 14:41:49 UTC
Reproduced.
Selection is cleared when component is removed from it's parent due to memory leaks.
Comment 3 Martin Entlicher 2011-03-08 14:30:41 UTC
Fixed by changeset:   190608:688575d70e00
http://hg.netbeans.org/main/rev/688575d70e00
Comment 4 Quality Engineering 2011-03-09 05:35:18 UTC
Integrated into 'main-golden', will be available in build *201103090000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/688575d70e00
User: mentlicher@netbeans.org
Log: #196233 Keep the selected lines when outline changes it's parent.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo