Bug 196126 - PHP FTP implementation breaks the filesystem constraints
PHP FTP implementation breaks the filesystem constraints
Status: RESOLVED DUPLICATE of bug 195141
Product: php
Classification: Unclassified
Component: FTP Support
7.0
All All
: P3 (vote)
: 7.1
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-28 19:39 UTC by phpsitesolutions
Modified: 2011-06-17 06:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.64 KB, text/plain)
2011-02-28 19:39 UTC, phpsitesolutions
Details

Note You need to log in before you can comment on or make changes to this bug.
Description phpsitesolutions 2011-02-28 19:39:46 UTC
This bug was originally marked as duplicate of bug 163666, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.0 Beta 2 (Build 201102140001)
VM: Java HotSpot(TM) Client VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
phpsitesolutions: Downloading files from FTP source




Stacktrace: 
java.lang.IllegalArgumentException: Duplicate in children list: /home/jon/Projects/WebCertificates/framework/web/CClientScript.php
Children: [MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/actions@cb2156:d84a93,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/auth@1f66796:ebe75f,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/filters@196107b:ab839c,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/form@bbe6b:2adc9a,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/helpers@1f9bd83:3e7e4c,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/js@74b547:155388b,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/renderers@22ef16:bef803,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/services@1432a60:16e0966,valid=true], MasterFileObject[/home/jon/Projects/WebCertificates/framework/web/widgets@140
   at org.openide.filesystems.Ordering.getOrder(Ordering.java:101)
   at org.openide.filesystems.FileUtil.getOrder(FileUtil.java:2162)
   at org.openide.loaders.FolderChildren$1R.run(FolderChildren.java:160)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968)
Comment 1 phpsitesolutions 2011-02-28 19:39:51 UTC
Created attachment 106570 [details]
stacktrace
Comment 2 Tomas Mysik 2011-06-03 10:22:54 UTC
Batch reassigning.
Comment 3 Tomas Mysik 2011-06-17 06:35:36 UTC
Should be already fixed.

*** This bug has been marked as a duplicate of bug 195141 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo