Bug 195955 - [HeapWalker] deadlock in processing of OQL query
[HeapWalker] deadlock in processing of OQL query
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows 7 x64
: P2 (vote)
: 7.0
Assigned To: Tomas Hurka
issues@profiler
: JDK_1.7, VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 16:42 UTC by Tomas Hurka
Modified: 2011-03-02 07:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (22.04 KB, text/plain)
2011-02-24 16:42 UTC, Tomas Hurka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2011-02-24 16:42:06 UTC
Created attachment 106419 [details]
Thread dump

See attached thread dump. Swing/AWT code invoked outside of AWT thread. See thread 
"pool-5-thread-1" and "HeapWalker Processor"
Comment 1 Tomas Hurka 2011-02-24 17:31:05 UTC
It looks like the deadlock is only reproducible with JDK7.
Comment 2 Tomas Hurka 2011-02-24 17:56:41 UTC
Fixed in profiler-main

changeset:   189318:87e43478996f
user:        Tomas Hurka <thurka@netbeans.org>
date:        Thu Feb 24 18:54:51 2011 +0100
summary:     bugfix #195955, invoke progressModel.setValue() and OQLControllerUI.ResultsUI.setResult() in AWT thread
Comment 3 Quality Engineering 2011-03-02 07:03:52 UTC
Integrated into 'main-golden', will be available in build *201103020001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/87e43478996f
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #195955, invoke progressModel.setValue() and OQLControllerUI.ResultsUI.setResult() in AWT thread


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo