Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195881 - cannot connect to repository using https:// method on JDK 7
cannot connect to repository using https:// method on JDK 7
Status: RESOLVED WORKSFORME
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 17:16 UTC by Stepan Zebra
Modified: 2012-03-19 15:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (35.72 KB, text/plain)
2011-02-23 17:16 UTC, Stepan Zebra
Details
thread dump (18.20 KB, text/plain)
2011-02-23 17:17 UTC, Stepan Zebra
Details
thread dump jdk6 solaris11 (18.05 KB, text/plain)
2011-03-04 10:11 UTC, Stepan Zebra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zebra 2011-02-23 17:16:51 UTC
Created attachment 106350 [details]
IDE log

Product Version: NetBeans IDE Dev (Build 201102230001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Linux version 2.6.32-28-generic running on i386; UTF-8; en_US (nb)

This issue is JDK 7 related. It doesn't occur on JDK 6.

When running on JDK 7 i cannot connect to a repository via https://. Other methods work fine. Connection setting should be correct, as i can connect with them, when i start IDE on JDK 6.

Steps to reproduce:
1) Start IDE on JDK 7
2) From main menu select Team > Subversion > Checkout...
3) Enter valid https:// connection settings
4) Click Next to proceed
5) Connecting to Subversion Repository appears, but nothing happens

There is no exception thrown, but the dialog never finishes, so it needs to be manually canceled.
Comment 1 Stepan Zebra 2011-02-23 17:17:23 UTC
Created attachment 106351 [details]
thread dump
Comment 2 Stepan Zebra 2011-02-23 17:19:26 UTC
Also, this issue happens only when SVN is running on svnkit.
Comment 3 Stepan Zebra 2011-03-04 10:11:57 UTC
Created attachment 106701 [details]
thread dump jdk6 solaris11

I was able to reproduce this issue on JDK 6 today. So now it seems, that it's not just JDK 7 problem.

I was working on Solaris 11 Express. Those were my settings:

Product Version: NetBeans IDE Dev (Build 201103020001)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: SunOS version 5.11 running on x86; UTF-8; en_US (nb)

I can confirm that it's a svnkit problem. Https connection via commandline have been possible on every tested setting.
Comment 4 Marian Mirilovic 2011-06-02 13:17:07 UTC
Ondra, would be nice to have this fixed in 7.0.1 ... do you plan to do so ?
Comment 5 Ondrej Vrabec 2011-06-02 13:27:32 UTC
(In reply to comment #4)
> Ondra, would be nice to have this fixed in 7.0.1 ... do you plan to do so ?
Probably not. It seems to be a bug in svnkit (3rd party lib) so we need to wait for them to fix it. And honestly it's probably not a critical problem, it seems to manifest only with repositories with an invalid certificate (as our test repository has). Regular users with their repositories should be fine.
Comment 6 Ondrej Vrabec 2012-03-19 08:55:53 UTC
Stepan, could you test this once again with svnkit 1.7 and latest JDK 1.7?
Comment 7 Stepan Zebra 2012-03-19 15:12:14 UTC
(In reply to comment #6)
> Stepan, could you test this once again with svnkit 1.7 and latest JDK 1.7?

Actually, after some testing, I'm not able to reproduce this since I've moved the test repositories to the new server and configured the https with a new (self-signed) certificate.
Not sure what exactly was wrong with the old server and it's certificate - it wasn't set up by myself.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo