Bug 195871 - No "Toggle Comment" Functinality in .ini Files
No "Toggle Comment" Functinality in .ini Files
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
7.3.1
All All
: P3 with 3 votes (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
: USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 15:11 UTC by hobbysoldat
Modified: 2016-07-07 07:30 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hobbysoldat 2011-02-23 15:11:55 UTC
When editing .ini Files, I do sometimes want to quickly comment or uncomment something, like it is possible in .php Files or in most other Files.

Since you claim to have .ini Support in Netbeans 7.0 I would rate this as an important and missing convenience Feature. And aren't IDEs all about that? Else i could use vi ;D

I think this should be fairly easy to implement, and maybe the current support for PHP can be adapted... PHP needs //, INI files need ; at the line start...

I am really missing this feature, and hoped it would appear in the Beta II but, it did not ... 

And do not forget about the CTRL + SHIFT + C shortcut ^.^
Comment 1 hobbysoldat 2011-02-23 15:14:28 UTC
STEPS TO REPRODUCE:

1) open any ini file (create one if you want)
2) try to go to SOURCE -> Toggle Comments - it will be greyed out

EXPECTED RESULTS:

1) same
2) toggle adds or removes semicolons at the beginning of the file for the selected line
Comment 2 descent89 2011-03-27 13:02:32 UTC
voted

this is a must have for lazy web developer :D
Comment 3 wernerm 2013-05-13 19:45:05 UTC
Voted too

This has (still) not been implemented in 7.3 

I miss this functionality daily as I have to work with lots of ini files...
Comment 4 Martin Balin 2016-07-07 07:30:15 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo