Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195851 - Directives aren't added automatically
Directives aren't added automatically
Status: RESOLVED WONTFIX
Product: php
Classification: Unclassified
Component: Editor
7.0
All All
: P3 (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 12:00 UTC by Vladimir Riha
Modified: 2012-04-24 14:42 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-02-23 12:00:11 UTC
Info:
Product Version: NetBeans IDE Dev (Build 201102230001)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Linux version 2.6.32-24-generic running on i386; UTF-8; en_US (nb)

Steps to reproduce it:
1. Create a function in PHP file.
2. In another PHP file, invoke code completion so that that function is available. Select that function and press Enter.
3. Require directive is supposed to be added for the corresponding file but nothing happened.
Comment 1 Petr Pisl 2011-02-23 15:55:24 UTC
This is not supported now. The reason is that PHP projects often use autoload functions.

Probably there can be an project option, whether user wants to add automatically require, require_once, include or include_once.

Marking as enhancement.
Comment 2 schkovich 2011-03-14 07:27:49 UTC
Using autoloader is de facto standard: http://groups.google.com/group/php-standards/web/psr-0-final-proposal

IMHO, proposed enchantment is outdated and should not be implemented.
Comment 3 Ondrej Brejla 2012-04-24 14:42:00 UTC
Won't fix for me since autoloading is a standard for years.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo