Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195850 - AssertionError: start=124 newStart=110 jts=JoinedTokenSequence[ContextDataTokenSequence[CURRENT,ts=TokenSequence for text/x-php5/text/html at tokenIndex=0. TokenList contains 1 tokens: *[0]: <null-text> <110,111> TEXT[0] DefT, la=1, st=State(hash=4343092,
AssertionError: start=124 newStart=110 jts=JoinedTokenSequence[ContextDataTok...
Status: RESOLVED DUPLICATE of bug 204222
Product: web
Classification: Unclassified
Component: CSS Visual Tools
7.0
PC Windows XP
: P3 (vote)
: 7.1
Assigned To: David Konecny
issues@javaee
:
: 196086 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 11:30 UTC by Vladimir Riha
Modified: 2012-04-17 23:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (46.33 KB, text/plain)
2011-02-23 11:31 UTC, Vladimir Riha
Details
another log (88.17 KB, application/octet-stream)
2011-03-14 08:33 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-02-23 11:30:35 UTC
Info
Product Version: NetBeans IDE Dev (Build 201102230001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

IDE log attached

What caused it:
1. Create new default php project
2. Create new php file
3. Type function moje(){} on the line before ?>
4. Hit enter several times with cursor having between {} brackets
Comment 1 Vladimir Riha 2011-02-23 11:31:07 UTC
Created attachment 106327 [details]
IDE log
Comment 2 Petr Pisl 2011-02-23 17:06:50 UTC
From the log the problem is in css formatter -> reassigning.
Comment 3 David Konecny 2011-02-24 22:41:15 UTC
Similar case as issue 195858 - I cannot reproduce it and not really sure what's happening. Report, are you able to always reproduce it? What about on JDK6?
Comment 4 Marian Mirilovic 2011-02-25 12:05:36 UTC
Incomplete ? 

Lada, could you also try to test the same scenario on JDK 6 + JDK 7 & Ubuntu ? Thanks in advance. 

Closing as Worksforme for now, thus I am not able to reproduce it on JDK7 (130) & Ubuntu 10.10 x64.
Comment 5 Vladimir Riha 2011-02-25 22:06:04 UTC
Marian,
I'll test combination of JDK7&Ubuntu on Monday, I tried to reproduce it on different machine with Ubuntu, JDK6 and the latest build of NB and without any success, seems to work fine.

Tested on:
Product Version: NetBeans IDE Dev (Build 201102250001)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Linux version 2.6.35-22-generic running on i386; UTF-8; cs_CZ (nb)
Comment 6 Marian Mirilovic 2011-02-26 06:55:02 UTC
(In reply to comment #5)
> I'll test combination of JDK7&Ubuntu on Monday, I tried to reproduce it on
> different machine with Ubuntu, JDK6 and the latest build of NB and without any
> success, seems to work fine.

Thanks for quick update
Comment 7 Vladimir Riha 2011-02-28 09:42:40 UTC
Ok, I reproduce it on
Product Version: NetBeans IDE Dev (Build 201102280001)
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

It was reported as Exception #487891. Just update, I pressed Enter just once and the exception was thrown
Comment 8 Vladimir Riha 2011-02-28 09:53:06 UTC
*** Bug 196086 has been marked as a duplicate of this bug. ***
Comment 9 Vladimir Riha 2011-02-28 10:24:09 UTC
Ok, so I'm not able to reproduce it on Linux with both, JDK6 and JDK7.

Product Version: NetBeans IDE Dev (Build 201102280001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
Java: 1.6.0_24; Java HotSpot(TM) Client VM 19.1-b02
System: Linux version 2.6.32-24-generic running on i386; UTF-8; en_US (nb)
Comment 10 David Konecny 2011-03-01 01:19:16 UTC
Valid issue on Windows.
Comment 11 Vladimir Riha 2011-03-14 08:33:20 UTC
Created attachment 106966 [details]
another log

Another log...

What caused it:
1. In PHP project, created new PHP file
2. Placed cursor after "*/"and pressed enter 3 times
Comment 12 David Konecny 2012-04-17 23:29:05 UTC

*** This bug has been marked as a duplicate of bug 204222 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo