Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195805 - Dialogs are empty
Dialogs are empty
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.0
PC Windows XP
: P2 (vote)
: 7.0.1
Assigned To: Stanislav Aubrecht
issues@platform
fix-in-nb701
:
: 188880 192654 194436 196025 197103 197260 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-22 13:36 UTC by Vladimir Riha
Modified: 2012-04-05 06:37 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (19.48 KB, image/jpeg)
2011-02-22 13:52 UTC, Vladimir Riha
Details
log from console (51.75 KB, text/plain)
2011-02-22 15:06 UTC, Vladimir Riha
Details
Thread dump. (20.07 KB, text/plain)
2011-05-09 12:25 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2011-02-22 13:36:34 UTC
When I wanted to report problem after Exception dialog was thrown, Report Problem dialog appeared but it looked empty, without any form fields, I gave him about 4 minutes and nothing changed.
Comment 1 Stanislav Aubrecht 2011-02-22 13:42:15 UTC
thanks for reporting but pls attach a screen shot and also the content of your IDE log and reopen this issue, thanks
Comment 2 Vladimir Riha 2011-02-22 13:52:35 UTC
Created attachment 106287 [details]
screenshot
Comment 3 Vladimir Riha 2011-02-22 14:00:17 UTC
Unfortunately I have already restarted Netbeans for a few times and the log has been rewritten. I will add it if this problem will occur again and then reopen this issue.
Comment 4 Marian Mirilovic 2011-02-22 14:13:40 UTC
Vladimir, are you able to reproduce it ? If, so could you write down what will happen with context of the dialog once you resize it ? I mean, would be the content shown or not ?

In case yes, I think this is a duplicate of issue 194436, but this one is reported against Windows and that would be a big problem.


Also is important to add at least JDK version/build number, NB build number and Operating System into this issue. Thanks in advance.
Comment 5 Vladimir Riha 2011-02-22 14:18:44 UTC
Info:
Product Version: NetBeans IDE Dev (Build 201102220001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Marian, I cannot reproduce it, I tried to open several dialogs that I have never opened before and it works fine
Comment 6 Vladimir Riha 2011-02-22 15:05:28 UTC
I was able to reproduce it, again with Report Problem dialog. When I try to resize the dialog, the content was shown.

Log from console is attached.
Comment 7 Vladimir Riha 2011-02-22 15:06:21 UTC
Created attachment 106300 [details]
log from console

Info:
Product Version: NetBeans IDE Dev (Build 201102220001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 8 Marian Mirilovic 2011-02-23 18:08:21 UTC
*** Bug 192654 has been marked as a duplicate of this bug. ***
Comment 9 Marian Mirilovic 2011-02-28 07:43:58 UTC
*** Bug 196025 has been marked as a duplicate of this bug. ***
Comment 10 Tomas Danek 2011-03-28 17:05:36 UTC
*** Bug 197103 has been marked as a duplicate of this bug. ***
Comment 11 Tomas Danek 2011-03-31 09:23:06 UTC
*** Bug 197260 has been marked as a duplicate of this bug. ***
Comment 12 Jiri Skrivanek 2011-05-09 12:25:19 UTC
Created attachment 108194 [details]
Thread dump.

To reproduce:
- start IDE with JDK 1.7
- go to Services tab
- expand Databases node and when exception is thrown, click "Review and Report Problem" button

Product Version: NetBeans IDE Dev (Build 201105090000)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b10
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)
Comment 13 Marian Mirilovic 2011-06-03 13:04:04 UTC
This has to be either fixed in our code or in JDK
Comment 14 Stanislav Aubrecht 2011-06-09 13:47:48 UTC
*** Bug 194436 has been marked as a duplicate of this bug. ***
Comment 15 Stanislav Aubrecht 2011-06-09 13:49:34 UTC
i still cannot reproduce but let's try this: core-main 13a10c846626
Comment 16 Stanislav Aubrecht 2011-06-09 14:17:47 UTC
release701 5aaf4645d362
Comment 17 Marian Mirilovic 2011-06-10 09:30:40 UTC
*** Bug 188880 has been marked as a duplicate of this bug. ***
Comment 18 Quality Engineering 2011-06-11 04:20:27 UTC
Integrated into 'releases'
Changeset: http://hg.netbeans.org/releases/rev/5aaf4645d362
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #195805 - attempt to fix empty dialog windows
(transplanted from 13a10c846626ec01f2460ac995c09de076e81327)
Comment 19 Quality Engineering 2011-06-11 15:16:49 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/13a10c846626
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #195805 - attempt to fix empty dialog windows
Comment 20 Vladimir Riha 2012-04-05 06:37:34 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo