Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195797 - IDE deadlock, when Help window is open
IDE deadlock, when Help window is open
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Help System
7.0
PC Linux
: P1 (vote)
: 7.0
Assigned To: issues@platform
issues@platform
jdk_bug_6993171 fix-in-nb701
:
: 194883 196033 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-22 11:42 UTC by asenk
Modified: 2011-06-09 07:19 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (28.17 KB, text/plain)
2011-02-22 13:55 UTC, asenk
Details
thread-dump (14.04 KB, text/plain)
2011-02-22 13:58 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description asenk 2011-02-22 11:42:58 UTC
Product Version: NetBeans IDE Dev (Build 201102220001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Linux version 2.6.32-24-generic running on i386; UTF-8; en_US (nb)

1. Start IDE with fresh userdir
2. Press F1
3. IDE DEADLOCK
Comment 1 Marian Mirilovic 2011-02-22 12:12:27 UTC
Adam, could you please generate thread-dump at the time of deadlock and attach it here ?
http://wiki.netbeans.org/GenerateThreadDump
Thanks in advance.
Comment 2 asenk 2011-02-22 13:55:03 UTC
Created attachment 106288 [details]
Thread dump
Comment 3 asenk 2011-02-22 13:57:42 UTC
There were no deadlock when i tried to repeat this bug.
Better way to reconstruct:
1. Start IDE with fresh userdir
-------------------------------------------
1.5 CREATE A NEW PROJECT
-------------------------------------------
2. Press F1
3. IDE DEADLOCK
Comment 4 Marian Mirilovic 2011-02-22 13:58:43 UTC
Created attachment 106290 [details]
thread-dump
Comment 5 Marian Mirilovic 2011-02-22 14:07:18 UTC
*** Bug 194883 has been marked as a duplicate of this bug. ***
Comment 6 Stanislav Aubrecht 2011-02-23 10:35:38 UTC
this a bug in JDK 7 where it's no more safe to call repaint off the event dispatch thread. there are probably some duplicates in editor team.
Comment 7 Marian Mirilovic 2011-02-28 07:40:47 UTC
*** Bug 196033 has been marked as a duplicate of this bug. ***
Comment 8 Petr Jiricka 2011-03-04 09:56:29 UTC
Do we have a URL for the JDK bug? If a bug against JDK was filed, we should mark this one with the NO70 keyword.
Comment 9 Antonin Nebuzelsky 2011-03-21 12:15:46 UTC
JDK bug #6993171 already covers this problem. The bug has been marked fixed in JDK7 b132.

Closing wontfix on our side.

Can someone who has been able to reproduce the problem reliably verify with the latest JDK7 build available (see http://download.java.net/jdk7/) that it really fixed this bug?
Comment 10 asenk 2011-06-08 09:11:35 UTC
Verified on

Product Version: NetBeans IDE 7.0.1 Dev (Build 201106072116)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b15
System: Linux version 2.6.32-32-generic running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo