Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195790 - 70cat [refactor] Deadlock from calling repaint from non-AWT-EDT
70cat [refactor] Deadlock from calling repaint from non-AWT-EDT
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.0
PC Windows XP
: P1 (vote)
: 7.0
Assigned To: Antonin Nebuzelsky
issues@platform
jdk_bug_6993171 fix-in-nb701
:
: 195058 195813 195870 195996 196118 196124 196417 197174 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-22 03:52 UTC by manikantannaren
Modified: 2011-06-09 07:19 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (70.53 KB, text/plain)
2011-02-22 03:53 UTC, manikantannaren
Details
Messages log (41.70 KB, application/octet-stream)
2011-02-22 04:23 UTC, manikantannaren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manikantannaren 2011-02-22 03:52:27 UTC
[ BUILD # : 201102210501 ]
[ JDK VERSION : 1.7 ]

Created a new Java Class Library project
Created a new package.
Created a new class with Name SPIFactory
Select the class in the Project view and pressed Ctrl+R. 
Entered a new name. 
Hit enter
IDE Hangs

The same happens when I open the class in the editor
Right click on the class name and choose Refactor-->Rename.
Comment 1 manikantannaren 2011-02-22 03:53:25 UTC
Created attachment 106273 [details]
Thread dump
Comment 2 manikantannaren 2011-02-22 04:23:33 UTC
Created attachment 106274 [details]
Messages log
Comment 3 David Strupl 2011-02-22 08:59:50 UTC
This is a JDK7 bug tracked in their system under CR 6993171.
Comment 4 David Strupl 2011-02-23 07:57:47 UTC
*** Bug 195813 has been marked as a duplicate of this bug. ***
Comment 5 Jan Becicka 2011-02-23 15:59:56 UTC
*** Bug 195870 has been marked as a duplicate of this bug. ***
Comment 6 David Strupl 2011-02-24 10:27:47 UTC
*** Bug 195058 has been marked as a duplicate of this bug. ***
Comment 7 Ondrej Vrabec 2011-02-25 13:23:04 UTC
*** Bug 195996 has been marked as a duplicate of this bug. ***
Comment 8 Jan Lahoda 2011-03-01 13:33:33 UTC
*** Bug 196118 has been marked as a duplicate of this bug. ***
Comment 9 Jan Lahoda 2011-03-01 13:34:31 UTC
*** Bug 196124 has been marked as a duplicate of this bug. ***
Comment 10 Jesse Glick 2011-03-01 15:40:39 UTC
The IDE is unsafe to use with this bug, so I guess that's the end of JDK 7 testing until 7.0.1.
Comment 11 Jan Becicka 2011-03-08 08:51:33 UTC
*** Bug 196417 has been marked as a duplicate of this bug. ***
Comment 12 Marian Mirilovic 2011-03-29 07:56:00 UTC
*** Bug 197174 has been marked as a duplicate of this bug. ***
Comment 13 Marian Mirilovic 2011-06-08 19:31:45 UTC
Fixed in JDK 7 build 132

Verified in 
Product Version: NetBeans IDE 7.0.1 Dev (Build 201106072116)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b15


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo