Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195695 - Autocomplete of generic classes adds generic variables even if they already exist
Autocomplete of generic classes adds generic variables even if they already e...
Status: RESOLVED DUPLICATE of bug 142225
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-19 13:29 UTC by rcasha
Modified: 2011-02-21 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rcasha 2011-02-19 13:29:29 UTC
If I use Ctrl-space to autocomplete a class name that has generics, the generic tags are added even if they are already there.

for example, when I enter the following text:

private TreeMap<String,String> v = new Tree<String,String>();

..then place the cursor right between Tree and <String,String> and press Ctrl-space, the following will be produced:

private TreeMap<String,String> v = new TreeMap<> <String,String>();

Netbeans is 7.0beta2, running under JDK1.6 with the platform set to JDK1.7.
Comment 1 Dusan Balek 2011-02-21 10:59:10 UTC
Already reported. Thanks.

*** This bug has been marked as a duplicate of bug 142225 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo