Bug 195576 - NB silently fails compiling, can't run due to Uncompilable source code
NB silently fails compiling, can't run due to Uncompilable source code
Status: CLOSED DUPLICATE of bug 182009
Product: java
Classification: Unclassified
Component: Compiler
6.x
PC Windows 7 x64
: P2 with 1 vote (vote)
: 7.0
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-16 17:44 UTC by mikato
Modified: 2011-03-18 08:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Deploy on save checkbox in Project Properties (33.42 KB, image/png)
2011-02-28 15:55 UTC, mikato
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikato 2011-02-16 17:44:31 UTC
I just had this problem: "java.lang.RuntimeException: Uncompilable source code - missing method body, or declare abstract".  I can't say what triggered it besides just Build and Compile and Running my code.

I've had it before but was able to get around it somehow.  However this time I couldn't get around it at all.  Build and Compile appeared to work fine one time but then the thing wouldn't work when I hit the Run button and threw all kinds of exceptions.  Sometimes Build and Compile fails because it can't delete a particular JAR file and maybe that leads to this.

The one it stuck on after a while was (Tomcat Log):
SEVERE: Servlet.service() for servlet jsp threw exception
java.lang.RuntimeException: Uncompilable source code - missing method body, or declare abstract
...

Earlier it was complaining about my code such as:
SEVERE: Servlet.service() for servlet jsp threw exception
org.apache.jasper.JasperException: /index.jsp(17,0) The value for the useBean class attribute caseDataUtil.caseDataHelper is invalid.
        at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40)

or: 
SEVERE: Servlet.service() for servlet jsp threw exception
java.lang.RuntimeException: Uncompilable source code - missing method body, or declare abstract
        at caseDataUtil.caseDataHelper.<init>(caseDataHelper.java:59)
        at org.apache.jsp.index_jsp._jspService(index_jsp.java:84)
...

There wasn't anything wrong with my code so I'd say this definitely isn't proper behavior.  I deleted the build and dist directories with no change as well, even though it did regenerate them.  Luckily Googling around I found one suggestion to disable the "Deploy on Save" checkbox in my project's Properties/Run screen and that worked.

related bugs? 163278, 178597
Comment 1 Petr Jiricka 2011-02-25 12:46:15 UTC
Yes I would guess this is related to Deploy on Save.

Also I am not sure this is correctly assigned to the JSP category, looks like the problem happens even without any JSP pages, with just Java code, right?

> related bugs? 163278, 178597

I think the first one is not related, but bug 178597 is probably related.
Comment 2 mikato 2011-02-25 17:34:07 UTC
Yes feel free to move it.  I don't know where it should go.  I don't see any choice for compiler and such.
Comment 3 Anton Chechel 2011-02-25 17:40:03 UTC
moving to serverplugins/infrastructure
Comment 4 Petr Hejl 2011-02-28 10:23:06 UTC
Compile on save, not deploy on save....
Comment 5 mikato 2011-02-28 15:55:45 UTC
Created attachment 106559 [details]
Deploy on save checkbox in Project Properties

It really says Deploy on Save on mine.  Attached screenshot.
Comment 6 Dusan Balek 2011-03-08 08:22:07 UTC
Do you have a reproducible test case - a simple project with exact steps to reproduce or could you share your project with us?
Comment 7 Dusan Balek 2011-03-08 09:56:02 UTC
Also could you please attach content of the NB cache (located located in
nb_user_dir/var/cache) or at least the content of the signature file of the affected class (located in nb_user_dir/var/cache/index/s*/java/*/classes)
Comment 8 Dusan Balek 2011-03-09 13:56:38 UTC

*** This bug has been marked as a duplicate of bug 182009 ***
Comment 9 Marian Mirilovic 2011-03-18 08:56:47 UTC
verified duplicate - closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo