Bug 195541 - AssertionError at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.loadIndexingContext
AssertionError at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerIm...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P3 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
EXCEPTIONS_REPORT
: RANDOM, THREAD
: 193456 194455 (view as bug list)
Depends on:
Blocks: 190182
  Show dependency treegraph
 
Reported: 2011-02-16 06:36 UTC by jcrim
Modified: 2011-04-06 21:09 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.08 KB, text/plain)
2011-02-16 06:36 UTC, jcrim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jcrim 2011-02-16 06:36:35 UTC
Build: NetBeans IDE 7.0 Beta (Build 201011152355)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.0-b17, Java(TM) SE Runtime Environment, 1.6.0_21-b07
OS: Windows 7

User Comments:
GUEST: expanding maven archetypes in New project

klauern: Looked at archetypes to create a project from.

klauern: Tried to create a new Maven project from an Archetype.  Was browsing the archetype listing (hadn't loaded yet).

jcrim: building/running a web app




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.loadIndexingContext(NexusRepositoryIndexerImpl.java:256)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.access$400(NexusRepositoryIndexerImpl.java:152)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl$3.run(NexusRepositoryIndexerImpl.java:525)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl$3.run(NexusRepositoryIndexerImpl.java:523)
   at org.openide.util.Mutex.writeAccess(Mutex.java:436)
   at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.updateIndexWithArtifacts(NexusRepositoryIndexerImpl.java:523)
Comment 1 jcrim 2011-02-16 06:36:40 UTC
Created attachment 106053 [details]
stacktrace
Comment 2 Jesse Glick 2011-02-16 21:59:04 UTC
I think a race condition in repoMutexMap.
Comment 3 Jesse Glick 2011-02-16 22:03:02 UTC
core-main #94a7612d9df7
Comment 4 Quality Engineering 2011-02-18 10:34:16 UTC
Integrated into 'main-golden', will be available in build *201102180501* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/94a7612d9df7
User: Jesse Glick <jglick@netbeans.org>
Log: #195541: AssertionError at org.netbeans.modules.maven.indexer.NexusRepositoryIndexerImpl.loadIndexingContext
Comment 5 Antonin Nebuzelsky 2011-03-07 14:58:16 UTC
*** Bug 193456 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2011-04-06 21:09:51 UTC
*** Bug 194455 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo