Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195537 - [70cat] Native IOOBE from processtreekiller.jar
[70cat] Native IOOBE from processtreekiller.jar
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Execution
7.0
All All
: P2 with 1 vote (vote)
: 8.1
Assigned To: Petr Hejl
issues@projects
EXCEPTIONS_REPORT
:
: 245474 249013 (view as bug list)
Depends on:
Blocks: 138116
  Show dependency treegraph
 
Reported: 2011-02-16 01:42 UTC by eltony81
Modified: 2015-06-16 08:48 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.63 KB, text/plain)
2011-02-16 01:42 UTC, eltony81
Details
stacktrace (2.51 KB, text/plain)
2014-01-24 00:31 UTC, Exceptions Reporter
Details
stacktrace (1.32 KB, text/plain)
2014-11-19 10:00 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eltony81 2011-02-16 01:42:53 UTC
Build: NetBeans IDE 7.0 Beta (Build 201011152355)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.1-b03-307, Java(TM) SE Runtime Environment, 1.6.0_22-b04-307-10M3261
OS: Mac OS X

Stacktrace: 
java.lang.IndexOutOfBoundsException: Bounds exceeds available space : size=262144, offset=262145
   at com.sun.jna.Memory.boundsCheck(Memory.java:149)
   at com.sun.jna.Memory.getByte(Memory.java:375)
   at org.netbeans.processtreekiller.ProcessTreeKiller$Darwin$DarwinProcess$1StringArrayMemory.skip0(ProcessTreeKiller.java:848)
   at org.netbeans.processtreekiller.ProcessTreeKiller$Darwin$DarwinProcess.parse(ProcessTreeKiller.java:901)
   at org.netbeans.processtreekiller.ProcessTreeKiller$Darwin$DarwinProcess.getEnvVars(ProcessTreeKiller.java:791)
   at org.netbeans.processtreekiller.ProcessTreeKiller$Unix.kill(ProcessTreeKiller.java:248)
Comment 1 eltony81 2011-02-16 01:42:58 UTC
Created attachment 106046 [details]
stacktrace
Comment 2 Jesse Glick 2011-02-16 16:52:34 UTC
Probably need to update lib from upstream Hudson source.
Comment 3 Jesse Glick 2012-03-22 00:05:35 UTC
Just one report.
Comment 4 Exceptions Reporter 2013-03-25 14:03:43 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=176707
Comment 5 Exceptions Reporter 2014-01-24 00:31:00 UTC
Created attachment 144327 [details]
stacktrace

Tried to execute JS Test Driver Tests
Comment 6 nojimage 2014-05-01 08:00:45 UTC
I had same problem.

I tried patch to processtreekiller, like https://github.com/jenkinsci/jenkins/commit/550678074ebeae884cf98850c4032141a936fe09 ( https://issues.jenkins-ci.org/browse/JENKINS-9634 )
it seem to work fine.
Comment 7 Exceptions Reporter 2014-10-23 20:55:59 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=176707
Comment 8 Tomas Stupka 2014-10-24 10:27:09 UTC
(In reply to Jesse Glick from comment #2)
> Probably need to update lib from upstream Hudson source.
Jesse, in case you remember, could you please elaborate on your comment 

thanks
Comment 9 Jesse Glick 2014-10-25 14:00:47 UTC
Do not remember the context, except that NB perhaps forked a very old version of a lib since updated upstream.
Comment 10 Tomas Stupka 2014-11-07 16:32:46 UTC
maven simply calls ExternalProcessSupport.destroy(prcs, env);

reassigning for further evaluation
Comment 11 Jan Becicka 2014-11-19 10:00:57 UTC
Created attachment 150566 [details]
stacktrace

When stopping jetty server
Comment 12 Petr Hejl 2015-03-03 13:01:04 UTC
Should be fixed in web-main ceb0230b5e0f. Please verify.
Comment 13 Quality Engineering 2015-03-04 03:57:21 UTC
Integrated into 'main-silver', will be available in build *201503040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ceb0230b5e0f
User: Petr Hejl <phejl@netbeans.org>
Log: #195537 - [70cat] Native IOOBE from processtreekiller.jar
Comment 14 Petr Hejl 2015-03-12 13:19:39 UTC
*** Bug 245474 has been marked as a duplicate of this bug. ***
Comment 15 Petr Hejl 2015-06-16 08:48:41 UTC
*** Bug 249013 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo