Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195381 - jdk.boot.jar warning
jdk.boot.jar warning
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Code
7.0
PC All
: P4 with 2 votes (vote)
: 7.0.1
Assigned To: Martin Entlicher
issues@debugger
: NETFIX
: 197363 199884 200810 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-12 13:00 UTC by vanob
Modified: 2011-09-02 10:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch to ignore to warn about this file (967 bytes, patch)
2011-05-16 19:56 UTC, chrislovsund
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description vanob 2011-02-12 13:00:47 UTC
[ BUILD # : 201102111519 ]
[ JDK VERSION : 1.6.23 ]

I've created default Java Application project.
When I started debugger it gave me the following warning

Have no file for C:\Program Files (x86)\Java\jdk1.6\jre\lib\modules\jdk.boot.jar
Comment 1 ravindram 2011-04-03 17:25:00 UTC
*** Bug 197363 has been marked as a duplicate of this bug. ***
Comment 2 zolta 2011-04-11 15:50:24 UTC
I can confirm this on Debian 
with NB daily build as of 2011-04-11
and with 6.9.1 
not only a warning also causes debuging problem 
continue (F5) doesn't stop at the next breakpoint
May be related to JUnit?
Comment 3 zolta 2011-04-11 21:53:33 UTC
(In reply to comment #2)
> I can confirm this on Debian 
> with NB daily build as of 2011-04-11
> and with 6.9.1 
> not only a warning also causes debuging problem 
> continue (F5) doesn't stop at the next breakpoint
> May be related to JUnit?

If I think it over calmly this is not a debugger problem
 but an extra and unneccesary java platform class jar file is added when NB recognizes the java platform. 
it seems to happen with 1.6u23 and 1.6u24
Comment 4 chrislovsund 2011-05-16 19:56:45 UTC
Created attachment 108333 [details]
Patch to ignore to warn about this file

Ignore was already done for two other paths.
Comment 5 Jiri Kovalsky 2011-05-17 09:09:50 UTC
Martin, what do you think about this patch? Can you please review and integrate it? Thanks!
Comment 6 Martin Entlicher 2011-05-18 11:32:10 UTC
Thanks for the patch, it looks fine.
Comment 7 Jiri Kovalsky 2011-05-18 13:45:27 UTC
Thanks. I have added this issue to NetFIXed [1] issues.

[1] http://wiki.netbeans.org/NetFIXIssues
Comment 8 Martin Entlicher 2011-05-19 16:06:20 UTC
The patch applied as changeset:   198651:6570a59a5c98
http://hg.netbeans.org/main/rev/c1d08ee5e078

And transplanted to 7.0.1:
http://hg.netbeans.org/releases/rev/6570a59a5c98
Comment 9 Jiri Kovalsky 2011-05-19 18:49:39 UTC
Thank you Martin and special thanks to Christian for your patch!
Comment 10 Quality Engineering 2011-05-20 08:56:58 UTC
Integrated into 'main-golden', will be available in build *201105200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c1d08ee5e078
User: mentlicher@netbeans.org
Log: #195381 Do not print warning about missing jdk.boot.jar.
Comment 11 Martin Entlicher 2011-07-12 12:05:29 UTC
*** Bug 199884 has been marked as a duplicate of this bug. ***
Comment 12 Martin Entlicher 2011-08-10 20:17:36 UTC
*** Bug 200810 has been marked as a duplicate of this bug. ***
Comment 13 omarovs 2011-09-02 08:43:26 UTC
Hi, I have problems to add the patch, can  someone can help me, if you can make step by step how to implement the patch
Comment 14 Martin Entlicher 2011-09-02 09:06:09 UTC
The patch is a part of NetBeans 7.0.1, therefore upgrading to 7.0.1 should solve this.
Comment 15 omarovs 2011-09-02 09:48:34 UTC
Comment on attachment 108333 [details]
Patch to ignore to warn about this file

Can you make more explicit how to patch, because it display this message: the patch cannot be applied, i already try everything, but i cannot make the debugger works.
Comment 16 Jiri Kovalsky 2011-09-02 09:55:33 UTC
Which version of NetBeans do you have installed Omar? If it's 7.0, please invoke "Tools > Plugins" from main menu, switch to "Updates" tab, check both updates and click "Update" button and follow instructions. After IDE restarts, repeat the same procedure to upgrade to NetBeans 7.0.1 which will fix this bug.

I hope this helps.
Comment 17 omarovs 2011-09-02 10:06:18 UTC
Yes I have version 7.0, sorry  I put my last message before i read your message, I made a mistake I thought I upgrated the last version, but i  didn´t, now i am installing the 7.01 version.

Thanks a lot for your time


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo