Bug 194940 - Java file class name didn't changed when renaming class via refactoring
Java file class name didn't changed when renaming class via refactoring
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
PC Windows XP
: P2 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
: REGRESSION
: 192498 194988 (view as bug list)
Depends on:
Blocks: 192222
  Show dependency treegraph
 
Reported: 2011-02-01 10:26 UTC by rov63rus
Modified: 2011-03-23 14:40 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
rename refactoring ignore case for java class file name (191.49 KB, image/png)
2011-02-01 10:26 UTC, rov63rus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rov63rus 2011-02-01 10:26:57 UTC
Created attachment 105541 [details]
rename refactoring ignore case for java class file name

I use 7.0 latest dev version.

Java file class name didn't changed when renaming class via refactoring.

I've changed the name for java class "WellTrjEvent" to "WelltrjEvent".
So that names are equals if ignore case. But Java compiler is case sensitive.
Comment 1 Jan Becicka 2011-02-01 10:46:14 UTC
It looks like file system is again out of sync. NB Explorer shows WelltrjEvent, while Windows Explorer shows WellTrjEvent.
Comment 2 Jan Becicka 2011-02-04 07:23:00 UTC
*** Bug 194988 has been marked as a duplicate of this bug. ***
Comment 3 Marian Mirilovic 2011-02-05 07:15:24 UTC
*** Bug 192498 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2011-02-16 17:01:16 UTC
Probably caused by bug 192222: the names are now internally updated, but not changed on the local disk.
Comment 5 Jaroslav Tulach 2011-02-16 17:43:13 UTC
ergonomics#5fbb54f9e6af
Comment 6 Quality Engineering 2011-02-18 10:33:52 UTC
Integrated into 'main-golden', will be available in build *201102180501* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5fbb54f9e6af
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #194940: Really rename the file on disk when case changes
Comment 7 devon_c_miller 2011-03-18 16:58:51 UTC
This sequence of operations does not work correctly in a case insensitive file system:

New Class, name Aaa
Rename Aaa to bbb
Rename bbb to aaa

The NetBeans Project window shows the file as "Aaa". The editor flags the class definition as an error with the message "class aaa is public, should be declared in a file named aaa.java"

The physical filesystem, the NetBeans Files window, and NetBeans Properties window all show the name as aaa.java.
Comment 8 devon_c_miller 2011-03-18 16:59:37 UTC
This is with dev 2011030150400

(In reply to comment #7)
> This sequence of operations does not work correctly in a case insensitive file
> system:
> 
> New Class, name Aaa
> Rename Aaa to bbb
> Rename bbb to aaa
> 
> The NetBeans Project window shows the file as "Aaa". The editor flags the class
> definition as an error with the message "class aaa is public, should be
> declared in a file named aaa.java"
> 
> The physical filesystem, the NetBeans Files window, and NetBeans Properties
> window all show the name as aaa.java.
Comment 9 Jaroslav Tulach 2011-03-19 21:54:44 UTC
OK, reproduced. Aaa -> bbb -> aaa yields "Aaa" which is wrong.
Comment 10 Jaroslav Tulach 2011-03-19 23:01:19 UTC
ergonomics#c0d12023f689
Comment 11 Jaroslav Tulach 2011-03-21 06:06:48 UTC
All tests passed. Merged to release70 as

changeset:   188af6f1a1ed
branch:      release70
Comment 12 Quality Engineering 2011-03-21 09:36:56 UTC
Integrated into 'main-golden', will be available in build *201103210400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c0d12023f689
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #194940: Always update the case after rename
Comment 13 Jaroslav Tulach 2011-03-23 10:27:10 UTC
*** Bug 196398 has been marked as a duplicate of this bug. ***
Comment 14 Jaroslav Tulach 2011-03-23 14:40:45 UTC
*** Bug 196398 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo