Bug 194885 - IDE hangs when I try to open project
IDE hangs when I try to open project
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
PC Mac OS X
: P2 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-30 20:37 UTC by Jan Becicka
Modified: 2011-02-16 11:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (33.77 KB, text/plain)
2011-01-30 20:52 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2011-01-30 20:37:57 UTC
full ide

  Product Version         = NetBeans IDE Dev (Build 110130-7ae8dd573ee3) (#7ae8dd573ee3)
  Operating System        = Mac OS X version 10.5.8 running on x86_64
  Java; VM; Vendor        = 1.6.0_22; Java HotSpot(TM) 64-Bit Server VM 17.1-b03-307; Apple Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_22-b04-307-9M3263


I tried to do some perf. testing, but I failed.
I started fresh build, with fresh userdir and I tried to open attached project.
I did 3 attempts and all failed. I tried to open very same project with 6.9.1 and it works.
Comment 1 Jan Becicka 2011-01-30 20:52:41 UTC
Created attachment 105500 [details]
Thread dump
Comment 2 Jan Becicka 2011-01-30 20:57:38 UTC
project file is located at http://www.uloz.to/7636820/lime6-zip
Comment 3 Jan Becicka 2011-01-31 14:40:14 UTC
works for me with today's build. Not P1 any more.
Comment 4 Jesse Glick 2011-01-31 16:03:40 UTC
I think the issue is FileUtil.holders vs. masterfs mutex, though I cannot see what code is inside that mutex - something in "Parsing & Indexing Loop" I presume. The question is probably whether HgUtils.isIgnored really needs to synchronously check SharabilityQuery.getSharability.
Comment 5 Jaroslav Tulach 2011-01-31 22:10:58 UTC
Calling 

	at org.netbeans.modules.masterfs.ProvidedExtensionsProxy.beforeCreate(ProvidedExtensionsProxy.java:148)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.createData(FolderObj.java:332)

with lock is probably the source of the problem.
Comment 6 Tomas Stupka 2011-02-01 13:43:56 UTC
on the other hand, like Jesse pointed out, a synchronous sharability check in mercurial should be avoided.
Comment 7 Tomas Stupka 2011-02-02 11:39:16 UTC
fixed in http://hg.netbeans.org/core-main/rev/268c57f3475f
Comment 8 Tomas Stupka 2011-02-02 11:40:29 UTC
(In reply to comment #7)
> fixed in http://hg.netbeans.org/core-main/rev/268c57f3475f
the part in mercurial
Comment 9 Quality Engineering 2011-02-03 05:57:55 UTC
Integrated into 'main-golden', will be available in build *201102030000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/268c57f3475f
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #194885 - IDE hangs when I try to open project
Comment 10 Jaroslav Tulach 2011-02-15 13:28:29 UTC
ergonomics#3ad71b0b100f
Comment 11 Quality Engineering 2011-02-16 11:38:56 UTC
Integrated into 'main-golden', will be available in build *201102160501* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3ad71b0b100f
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #194885: Don't call extensions.beforeCreate while holding mutex's write access


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo