Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 194773 - Maven projects: Show version in Projects and Files views root nodes
Maven projects: Show version in Projects and Files views root nodes
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.0
All All
: P3 with 4 votes (vote)
: 7.4
Assigned To: Milos Kleint
issues@projects
:
: 179571 227120 (view as bug list)
Depends on: 224536
Blocks: 227578
  Show dependency treegraph
 
Reported: 2011-01-27 14:04 UTC by pekarna
Modified: 2013-03-20 10:56 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pekarna 2011-01-27 14:04:37 UTC
Sometimes developers have more versions of the same project opened in the IDE.
It would be helpful if the root nodes in the Projects window has the version appended to the name.

For maven projects, this information is guaranteed to be in the pom.xml, so I gues this woulb be a quick fix.

Thanks for considering.
Comment 1 Jesse Glick 2011-01-27 14:24:54 UTC
While there are circumstances where this would be helpful, for most users this would just waste horizontal label space and be a distraction. The version is also available in the tool tip in the Projects node.
Comment 2 pekarna 2011-02-17 18:22:02 UTC
Those "circumstances" are quite often - every time when two versions of some project are compared.

How about making it configurable?
Comment 3 Jesse Glick 2011-02-17 21:58:47 UTC
We generally avoid adding configuration options unless it is pretty general and would be widely used (and the opposite choice would also be widely used). But a useful enhancement would be to display the version only if another project with the same coordinates except differing in version were also opened. This ensures that the extra visual space is used only when it would actually be differentiating information.
Comment 4 Milos Kleint 2012-02-17 11:49:09 UTC
BTW: since we use ${project.name} as project display in the projects view, one always has the option to add ${project.version} in the <name> element of your project..
Comment 5 markiewb 2013-01-06 12:48:10 UTC
I created a RFE for such a extension point - "Project Label Annotator". http://netbeans.org/bugzilla/show_bug.cgi?id=224536
Comment 6 Milos Kleint 2013-03-07 07:20:43 UTC
*** Bug 227120 has been marked as a duplicate of this bug. ***
Comment 7 Milos Kleint 2013-03-14 10:38:14 UTC
https://hg.netbeans.org/core-main/rev/69ca3e1caff3

allows to customize project's display name. 

The global definition is at $userhome/Preferences/org/netbeans/modules/maven.properties' property project.displayName

property netbeans.hint.displayName in pom.xml overrides even the global setting and can be inherited/shared by multiple projects or defined in settings.xml file or profiles.

in both cases, regular maven expressions apply - eg. ${project.artifactId} or ${basedir}

no UI (done or planned) apart from code completion hint in pom.xml's <properties> element


does not correctly interact with "Rename project" action. That one will still only edit the project.name xml element. No way around it anyway I guess.
Comment 8 markiewb 2013-03-15 08:25:57 UTC
(In reply to comment #7)
> https://hg.netbeans.org/core-main/rev/69ca3e1caff3
> 
> allows to customize project's display name. 
> 

Thank you! I will give it a try when it is integrated.

> no UI (done or planned) 
May I propose a patch for it?
Comment 9 Milos Kleint 2013-03-15 08:33:16 UTC
(In reply to comment #8)
> 
> > no UI (done or planned) 
> May I propose a patch for it?

sure. not entirely clear of both project and global value needs to be shown in UI. maybe just global option would be sufficient to show.
Comment 10 markiewb 2013-03-17 01:16:25 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > 
> > > no UI (done or planned) 
> > May I propose a patch for it?
> 
> sure. not entirely clear of both project and global value needs to be shown in
> UI. maybe just global option would be sufficient to show.

FYI: I created the follow-up issue http://netbeans.org/bugzilla/show_bug.cgi?id=227578 for this RFE.
Comment 11 Jesse Glick 2013-03-20 10:55:24 UTC
(In reply to comment #7)
> does not correctly interact with "Rename project" action. That one will still
> only edit the project.name xml element. No way around it anyway I guess.

Could revert the change to Info and only customize the root node’s displayName. That would solve that issue, at the expense of leaving the window title, Open Project label, etc. etc. as <name>.
Comment 12 Jesse Glick 2013-03-20 10:56:12 UTC
*** Bug 179571 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo