Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 194664 - IllegalStateException: endPosTable already set
IllegalStateException: endPosTable already set
Status: RESOLVED DUPLICATE of bug 196104
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-24 18:34 UTC by Jesse Glick
Modified: 2011-03-10 15:06 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.49 KB, text/plain)
2011-01-24 18:34 UTC, Jesse Glick
Details
stacktrace (3.49 KB, text/plain)
2011-01-24 19:09 UTC, Jesse Glick
Details
stacktrace (3.49 KB, text/plain)
2011-01-27 00:04 UTC, Jesse Glick
Details
stacktrace (3.63 KB, text/plain)
2011-01-27 10:58 UTC, Exceptions Reporter
Details
stacktrace (3.63 KB, text/plain)
2011-01-27 19:52 UTC, Alexander Simon
Details
stacktrace (3.49 KB, text/plain)
2011-02-18 06:27 UTC, javydreamercsw
Details
stacktrace (3.63 KB, text/plain)
2011-02-18 08:36 UTC, David Konecny
Details
stacktrace (3.49 KB, text/plain)
2011-03-06 19:25 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-01-24 18:34:21 UTC
Build: NetBeans IDE Dev (Build 110124-56c6ea78c1bb)
VM: Java HotSpot(TM) Client VM, 19.0-b09, Java(TM) SE Runtime Environment, 1.6.0_23-b05
OS: Linux

User Comments:
GUEST: working on a java project
error happend after/during renaming a package while debugging the project.




Stacktrace: 
java.lang.IllegalStateException: endPosTable already set
   at com.sun.tools.javac.util.DiagnosticSource.setEndPosTable(DiagnosticSource.java:137)
   at com.sun.tools.javac.util.Log.setEndPosTable(Log.java:255)
   at com.sun.tools.javac.main.JavaCompiler.parse(JavaCompiler.java:668)
   at com.sun.tools.javac.main.JavaCompiler.parseFiles(JavaCompiler.java:936)
   at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.<init>(JavacProcessingEnvironment.java:903)
   at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.next(JavacProcessingEnvironment.java:931)
Comment 1 Jesse Glick 2011-01-24 18:34:26 UTC
Created attachment 105310 [details]
stacktrace
Comment 2 Jesse Glick 2011-01-24 19:09:33 UTC
Created attachment 105316 [details]
stacktrace
Comment 3 Exceptions Reporter 2011-01-24 19:09:55 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=153500
Comment 4 Jesse Glick 2011-01-27 00:04:11 UTC
Created attachment 105387 [details]
stacktrace
Comment 5 Exceptions Reporter 2011-01-27 10:58:11 UTC
Created attachment 105397 [details]
stacktrace
Comment 6 Alexander Simon 2011-01-27 19:52:12 UTC
Created attachment 105418 [details]
stacktrace
Comment 7 javydreamercsw 2011-02-18 06:27:33 UTC
Created attachment 106138 [details]
stacktrace

Editing java clas in editor
Comment 8 David Konecny 2011-02-18 08:36:40 UTC
Created attachment 106140 [details]
stacktrace

just opened Beta2 build instead of Beta1 on NB sources
Comment 9 David Konecny 2011-03-06 19:25:23 UTC
Created attachment 106770 [details]
stacktrace
Comment 10 Exceptions Reporter 2011-03-09 09:48:54 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=153500
Comment 11 Dusan Balek 2011-03-10 12:26:22 UTC
Should be fixed together with #196104

*** This bug has been marked as a duplicate of bug 196104 ***
Comment 12 Jesse Glick 2011-03-10 15:06:16 UTC
(In reply to comment #11)
> Should be fixed [by] #196104

At least for this processor. Bug #196391 is relevant for the general case.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo